[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

correct way to upgrade package with dependencies



I'm using OBSD 2.7 with ports current.

ok, today I tried to build xfce from the ports tree.

Fetch, compile and fake install all worked fine, but when
it came to package installation it complained about wrong
versions of some libs (png, jpeg...).

Surely, this is no problem, I recompiled this package to
and, as expected, it complained about the lib already being
installed.

I know it would be the safest way if I removed the concerning
packages and then reinstall them from scratch, but this would
cost me much time and keystrokes.

Is there an "official" way to upgrade a port without 
removing the corresponding package before, which meant heaving
to break the dependencies? such as some "force overwrite" option?

seb 





Visit your host, monkey.org