[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Kernel config of NIC fails



Does anybody know why this is happening? Even with the distribution kernel of OpenBSD 2.3 i386, my LinkSys 10/100 NIC isn't being configured by the kernel. It's ethernet controller is a DECchip 21140A, as shown by the dmesg output.  
My second NIC, a D-Link 530/CT (DECchip 21041) gets configured and works fine.

Thanks for any assistance,
Steven Campbell

dmesg output follows:
__________________________________________________________________

OpenBSD 2.3 (SAMMY) #3: Sat Jul 11 14:50:58 EDT 1998
    campbel_(_at_)_cmn_(_dot_)_toronto_(_dot_)_on_(_dot_)_ca:/usr/src/sys/arch/i386/compile/SAMMY
cpu0: Intel Pentium/MMX ("GenuineIntel" 586-class) 200 MHz
cpu0: F00F bug workaround installed
BIOS mem  = 654336 conventional, 66060288 extended
real mem  = 66715648
avail mem = 60461056
using 840 buffers containing 3440640 bytes of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(cb) BIOS, date 01/21/98
bios0: pciinfo 0xf02e600c apminfo 0xf02e6028 diskinfo 0xf02e6050 cksumlen 1 memmap 0xf02e60cc
pci0 at mainbus0 bus 0: configuration mode 1 (bios)
pchb0 at pci0 dev 0 function 0 "Intel 82439TX System Controller (MTXC)" rev 0x01
"Intel 82371AB PIIX4 ISA Bridge" rev 0x01 at pci0 dev 1 function 0 not configured
"S3 ViRGE" rev 0x06 at pci0 dev 9 function 0 not configured
de0 at pci0 dev 10 function 0 "Digital Equipment DECchip 21140 (FasterNet)" rev 0x22: can't read ENET ROM (why=-3) (ffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffff
de0: 21140A [10-100Mb/s] pass 2.2 address unknownde1 at pci0 dev 11 function 0 "Digital Equipment DECchip 21041 (Tulip Pass 3)" rev 0x11: irq 10
de1: 21041 [10Mb/s] pass 1.1 address 00:80:c8:3c:45:60
de1: media: 1="10baseT" 2="Full Duplex 10baseT" 3="BNC" 4="AUI"
ahc0 at pci0 dev 12 function 0 "Adaptec AHA-2940 Ultra" rev 0x01: irq 11
ahc0: aic7880 Wide Channel, SCSI Id=7, 16 SCBs
scsibus0 at ahc0: 16 targets
de1: enabling 10baseT port
ahc0: target 0 synchronous at 10.0MHz, offset = 0x8
sd0 at scsibus0 targ 0 lun 0: <QUANTUM, MAVERICK 540S, 0901> SCSI2 0/direct fixed
sd0: 516MB, 2853 cyl, 4 head, 92 sec, 512 bytes/sec, 1057758 sec total
ahc0: target 3 synchronous at 10.0MHz, offset = 0xf
cd0 at scsibus0 targ 3 lun 0: <NEC, CD-ROM DRIVE:463, 1.05> SCSI2 5/cdrom removable
isa0 at mainbus0
lpt0 at isa0 port 0x378-0x37b irq 7
isadma0 at isa0
npx0 at isa0 port 0xf0-0xff: using exception 16
pccom0 at isa0 port 0x3f8-0x3ff irq 4: ns16550a, 16 byte fifo
pccom1 at isa0 port 0x2f8-0x2ff irq 3: ns16550a, 16 byte fifo
vt0 at isa0 port 0x60-0x6f irq 1: S3 ViRGE, 80 col, color, 8 scr, mf2-kbd
pms0 at vt0 irq 12
fdc0 at isa0 port 0x3f0-0x3f7 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
biomask 840 netmask c40 ttymask 1cc2
root on sd0a
pctr: user-level cycle counter enabled
dkcsum: sd0 matched BIOS disk 80
rootdev=0x400 rrootdev=0xd00 rawdev=0xd02

Visit your host, monkey.org