[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

DEC 5000/240 inst.




Greetings and Salutations,

I am trying to put OpenBSD onto a DEC 5000/240 from a DEC 3100.  I have
succeded in puting it to other 3100's as well as a 5000/200.

Currently I am booting BSD from the 3100, mounting drives from the other
machine and doing a:   dump | restore.

But with this 5000/240 (the first one I have tried) I can't seem to get
BSD to boot from the 3100's drive when it is connected to the 5000/240.

What happens is after it starts up local daemons and prints a date:

starting local daemons:.
Thu Nov 13 12:49:08 EST 1997

It gives me this:

le0: dropping chained buffer
le0: dropping chained buffer
le0: overflow
le0: recieve buffer error
le0: dropping chained buffer
le0: dropping chained buffer
le0: dropping chained buffer
le0: dropping chained buffer
le0: overflow
le0: dropping chained buffer
le0: dropping chained buffer
le0: dropping chained buffer
le0: dropping chained buffer
........  (a bunch of errors like the above) ....
Bus error ( core dumped)
panic: trap
syncing disks ...


except it freezes here.  It dosn't sink the disks, there is no disk
acrivity, nothing.  If I try to hit the system reset button, it doesn't
work.  I have to power off and turn back on.

If I start the 5000/240 up single, everything seems to be fine:

real mem = 67108864
avail mem = 60604416
using 844 buffers containing 3457024 bytes of memory
mainbus0 (root)
cpu0 at mainbus0: MIPS R3000 CPU Rev. 3.0 with MIPS R3010 FPC Rev. 4.0
tc0 at mainbus0: 25 MHz clock
asic at tc0 slot 3 offset 0x0
le0 at asic0 offset 0xc0000 priority 4: address 08:00:2b:28:ef:dc
le0: 32 recieve buffers, 8 transmit buffers
scc0 at asic0 offset 0x100000 priority 6
scc1 at asic0 offset 0x180000 priority 5
clock0 at asic0 offset 0x200000 priority 0
asc0 at asic0 offset 0x300000 priority 7
sfb0 at tc0 slot 0 offset 0x0 (1280x1024x8) (console)
Beginning old-style SCSI device autoconfiguration
rz0 ......

.... tells me the drives....

rz3 ....
rootdev-0x1508  rrootdev=0x3808  rawdev=0x380a

Then I am in single.

I ran iconfig ... no problem
I ran finger @otherhost ... no problem
I ran rdate @otherhost ... no problem
I ran date ... no problem - clock is clocking
I ran ntpdate ... it hangs with no return
                  (^C didn't work and neither did the reset button)
                  (I had to power off)
Getting back into single (as before)
I ran xntpd ... no problem
I ran ntpdate again ... same as before



Here is what I get when I type cnfg 3 at boot:

>>cnfg
   3:KNO3-AA DEC V5.1b  TCF0 ( 40 MB)
                             (enet:08:00:2b:28:ef:dc)
                             (SCSI=7)
         ... Drives ...
         dcache( 64KB), icache( 64 KB)
         mem( 0):  a0000000:21ffffff(32 MB)
         mem( 1):  a2000000:a27fffff(8 MB)
>>

Can someone help me?  I don't know what is going wrong, or why I am
hanging the way I do.

Thanks in advance for all the help,
Daniel Colpi
Purdue University
colpi_(_at_)_purdue_(_dot_)_edu


Visit your host, monkey.org