[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: i386/4083: No link on dc0 when configured for DHCP



The following reply was made to PR i386/4083; it has been noted by GNATS.

From: "Raymond C. Rodgers" <obsd_(_at_)_bbnk_(_dot_)_dhs_(_dot_)_org>
To: Andrew Basterfield <bob_(_at_)_cemetery_(_dot_)_homeunix_(_dot_)_org>
Cc: gnats_(_at_)_openbsd_(_dot_)_org, kwesterback_(_at_)_rogers_(_dot_)_com
Subject: Re: i386/4083: No link on dc0 when configured for DHCP
Date: Sun, 30 Jan 2005 17:29:32 -0800

 Here's the dmesg output from several different builds, all of which 
 exhibited the same problem. dmesg.txt is from the -stable with generic 
 kernel build #59, newly reinstalled on my machine today. The other two are 
 from -current kernel builds 221 and 231 respectively. I tried a build last 
 weekend as well, which also exhibited the problem, but it was too unstable 
 in general; causing crashes every few hours so I reinstalled -stable #59 
 today. As I mentioned in the sendbug message, I reported this problem in 
 December on the misc mailing list but it didn't get resolved, nor have I 
 heard from the individuals that said that they'd look into the matter.
 
 Raymond
 At 08:40 AM 1/30/2005, Andrew Basterfield wrote:
 >On Sun, 30 Jan 2005 06:52:15 -0800 (PST)
 >obsd_(_at_)_bbnk_(_dot_)_dhs_(_dot_)_org wrote:
 > > >Description:
 > >         With OpenBSD 3.6 stable through current, on boot or when
 > >         restarting networking with /etc/netstart, dc0 fails to find a
 > >         link as long as it is configured for DHCP. If configured for a
 > >         static IP address, OpenBSD has no problem configuring the
 > >         interface and utilizing it. I have been able to get the
 > >         controller up and usable by setting an "at" job at boot time
 > >         to bring the controller up with ifconfig, then run dhclient on
 > >         the interface, followed by pfctl and spamd-setup to achieve
 > >         normal operations. I first reported this on the misc mailing
 > >         list in late December, when I was using a custom kernel, but
 > >         the same problem occurs with -stable as well as with-current
 > >         through January 20. Due to stability problems, I have moved
 > >         back to 3.6 stable however, from which I am submitting this
 > >         report.
 >
 >dmesg? I would hope someone would have noticed by now if every dc(4) 
 >didn't work with dhcp.
 >
 > > >How-To-Repeat:
 > >         Configure dc0 to be an outside interface utilizing DHCP for
 > >         configuration.
 > > >Fix:
 > >         Manually or through an "at" job, bring the interface up with
 > >         ifconfig followed by dhclient, pfctl, and spamd-setup.
 >
 >less nasty than 'at', in /etc/hostname.dc0 you could try
 >
 >up
 >!dhclient dc0
 >
 >--bob
 
 Raymond C. Rodgers
 Home Page:      http://bbnk.dhs.org/~rrodgers/
                  http://www.j-a-n.net/
 OpenBSD 3.6 (GENERIC) #59: Fri Sep 17 12:32:57 MDT 2004
     deraadt_(_at_)_i386_(_dot_)_openbsd_(_dot_)_org:/usr/src/sys/arch/i386/compile/GENERIC
 cpu0: AMD Athlon(tm) XP 1700+ ("AuthenticAMD" 686-class) 1.47 GHz
 cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE
 real mem  = 267956224 (261676K)
 avail mem = 237486080 (231920K)
 using 3296 buffers containing 13500416 bytes (13184K) of memory
 mainbus0 (root)
 bios0 at mainbus0: AT/286+(e3) BIOS, date 01/28/03, BIOS32 rev. 0 @ 0xfb520
 apm0 at bios0: Power Management spec V1.2
 apm0: AC on, battery charge unknown
 pcibios0 at bios0: rev 2.1 @ 0xf0000/0xdf94
 pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfdef0/160 (8 entries)
 pcibios0: PCI Exclusive IRQs: 5 10 11 12
 pcibios0: PCI Interrupt Router at 000:17:0 ("VIA VT8366 ISA" rev 0x00)
 pcibios0: PCI bus #1 is the last bus
 bios0: ROM list: 0xc0000/0x8000 0xc8000/0x8000!
 cpu0 at mainbus0
 pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
 pchb0 at pci0 dev 0 function 0 "VIA VT8366 PCI" rev 0x00
 ppb0 at pci0 dev 1 function 0 "VIA VT8366 AGP" rev 0x00
 pci1 at ppb0 bus 1
 vga1 at pci0 dev 8 function 0 "Matrox MGA Millennium II 2164W" rev 0x00
 wsdisplay0 at vga1: console (80x25, vt100 emulation)
 wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
 dc0 at pci0 dev 9 function 0 "Lite-On PNIC-II" rev 0x25: irq 12, address 00:a0:cc:e0:38:8c
 dcphy0 at dc0 phy 31: internal PHY
 dc1 at pci0 dev 10 function 0 "Lite-On PNIC-II" rev 0x25: irq 10, address 00:a0:cc:e5:85:bf
 dcphy1 at dc1 phy 31: internal PHY
 cmpci0 at pci0 dev 14 function 0 "C-Media Electronics CMI8738/C3DX Audio" rev 0x10: irq 11
 audio0 at cmpci0
 pcib0 at pci0 dev 17 function 0 "VIA VT8366 ISA" rev 0x00
 pciide0 at pci0 dev 17 function 1 "VIA VT82C571 IDE" rev 0x06: ATA100, channel 0 configured to compatibility, channel 1 configured to compatibility
 atapiscsi0 at pciide0 channel 0 drive 0
 scsibus0 at atapiscsi0: 2 targets
 cd0 at scsibus0 targ 0 lun 0: <MITSUMI, CD-ROM FX120T !B, b03> SCSI0 5/cdrom removable
 cd0(pciide0:0:0): using PIO mode 3, DMA mode 1
 wd0 at pciide0 channel 1 drive 0: <Maxtor 6Y200P0>
 wd0: 16-sector PIO, LBA48, 194481MB, 398297088 sectors
 wd1 at pciide0 channel 1 drive 1: <Maxtor 91728D8>
 wd1: 16-sector PIO, LBA, 16479MB, 33750864 sectors
 wd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2
 wd1(pciide0:1:1): using PIO mode 4, Ultra-DMA mode 2
 uhci0 at pci0 dev 17 function 2 "VIA VT83C572 USB" rev 0x1b: irq 5
 usb0 at uhci0: USB revision 1.0
 uhub0 at usb0
 uhub0: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
 uhub0: 2 ports with 2 removable, self powered
 uhci1 at pci0 dev 17 function 3 "VIA VT83C572 USB" rev 0x1b: irq 5
 usb1 at uhci1: USB revision 1.0
 uhub1 at usb1
 uhub1: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
 uhub1: 2 ports with 2 removable, self powered
 uhci2 at pci0 dev 17 function 4 "VIA VT83C572 USB" rev 0x1b: irq 5
 usb2 at uhci2: USB revision 1.0
 uhub2 at usb2
 uhub2: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
 uhub2: 2 ports with 2 removable, self powered
 vr0 at pci0 dev 18 function 0 "VIA RhineII-2" rev 0x70: irq 11 address 00:50:2c:00:d5:da
 icsphy0 at vr0 phy 1: ICS1893 10/100 media interface, rev. 1
 isa0 at pcib0
 isadma0 at isa0
 pckbc0 at isa0 port 0x60/5
 pckbd0 at pckbc0 (kbd slot)
 pckbc0: using irq 1 for kbd slot
 wskbd0 at pckbd0: console keyboard, using wsdisplay0
 pcppi0 at isa0 port 0x61
 midi0 at pcppi0: <PC speaker>
 sysbeep0 at pcppi0
 lpt0 at isa0 port 0x378/4 irq 7
 it0 at isa0 port 0x290/8: IT87
 npx0 at isa0 port 0xf0/16: using exception 16
 biomask e37d netmask ff7d ttymask ffff
 pctr: user-level cycle counter enabled
 mtrr: Pentium Pro MTRR support
 dkcsum: wd0 matched BIOS disk 80
 dkcsum: wd1 matched BIOS disk 81
 root on wd0a
 rootdev=0x0 rrootdev=0x300 rawdev=0x302
 uhidev0 at uhub1 port 1 configuration 1 interface 0
 uhidev0: Microsoft Microsoft IntelliMouse\M-. Optical, rev 1.10/1.08, addr 2, iclass 3/1
 ums0 at uhidev0: 5 buttons and Z dir.
 wsmouse0 at ums0 mux 0
 OpenBSD 3.6-current (GENERIC) #221: Sat Dec 25 15:57:31 MST 2004
     deraadt_(_at_)_i386_(_dot_)_openbsd_(_dot_)_org:/usr/src/sys/arch/i386/compile/GENERIC
 cpu0: AMD Athlon(tm) XP 1700+ ("AuthenticAMD" 686-class) 1.47 GHz
 cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE
 real mem  = 267952128 (261672K)
 avail mem = 237678592 (232108K)
 using 3296 buffers containing 13500416 bytes (13184K) of memory
 mainbus0 (root)
 bios0 at mainbus0: AT/286+(e3) BIOS, date 01/28/03, BIOS32 rev. 0 @ 0xfb520
 apm0 at bios0: Power Management spec V1.2
 apm0: AC on, battery charge unknown
 pcibios0 at bios0: rev 2.1 @ 0xf0000/0xdf94
 pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfdef0/160 (8 entries)
 pcibios0: PCI Exclusive IRQs: 3 5 10 11
 pcibios0: PCI Interrupt Router at 000:17:0 ("VIA VT8366 ISA" rev 0x00)
 pcibios0: PCI bus #1 is the last bus
 bios0: ROM list: 0xc0000/0x8000 0xc8000/0x8000!
 cpu0 at mainbus0
 pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
 pchb0 at pci0 dev 0 function 0 "VIA VT8366 PCI" rev 0x00
 ppb0 at pci0 dev 1 function 0 "VIA VT8366 AGP" rev 0x00
 pci1 at ppb0 bus 1
 vga1 at pci0 dev 8 function 0 "Matrox MGA Millennium II 2164W" rev 0x00
 wsdisplay0 at vga1: console (80x25, vt100 emulation)
 wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
 dc0 at pci0 dev 9 function 0 "Lite-On PNIC-II" rev 0x25: irq 5, address 00:a0:cc:e0:38:8c
 dcphy0 at dc0 phy 31: internal PHY
 dc1 at pci0 dev 10 function 0 "Lite-On PNIC-II" rev 0x25: irq 10, address 00:a0:cc:e5:85:bf
 dcphy1 at dc1 phy 31: internal PHY
 cmpci0 at pci0 dev 14 function 0 "C-Media Electronics CMI8738/C3DX Audio" rev 0x10: irq 11
 audio0 at cmpci0
 pcib0 at pci0 dev 17 function 0 "VIA VT8366 ISA" rev 0x00
 pciide0 at pci0 dev 17 function 1 "VIA VT82C571 IDE" rev 0x06: ATA100, channel 0 configured to compatibility, channel 1 configured to compatibility
 atapiscsi0 at pciide0 channel 0 drive 0
 scsibus0 at atapiscsi0: 2 targets
 cd0 at scsibus0 targ 0 lun 0: <MITSUMI, CD-ROM FX120T !B, b03> SCSI0 5/cdrom removable
 cd0(pciide0:0:0): using PIO mode 3, DMA mode 1
 wd0 at pciide0 channel 1 drive 0: <Maxtor 6Y200P0>
 wd0: 16-sector PIO, LBA48, 194481MB, 398297088 sectors
 wd1 at pciide0 channel 1 drive 1: <Maxtor 91728D8>
 wd1: 16-sector PIO, LBA, 16479MB, 33750864 sectors
 wd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2
 wd1(pciide0:1:1): using PIO mode 4, Ultra-DMA mode 2
 uhci0 at pci0 dev 17 function 2 "VIA VT83C572 USB" rev 0x1b: irq 3
 usb0 at uhci0: USB revision 1.0
 uhub0 at usb0
 uhub0: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
 uhub0: 2 ports with 2 removable, self powered
 uhci1 at pci0 dev 17 function 3 "VIA VT83C572 USB" rev 0x1b: irq 3
 usb1 at uhci1: USB revision 1.0
 uhub1 at usb1
 uhub1: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
 uhub1: 2 ports with 2 removable, self powered
 uhci2 at pci0 dev 17 function 4 "VIA VT83C572 USB" rev 0x1b: irq 3
 usb2 at uhci2: USB revision 1.0
 uhub2 at usb2
 uhub2: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
 uhub2: 2 ports with 2 removable, self powered
 vr0 at pci0 dev 18 function 0 "VIA RhineII-2" rev 0x70: irq 11 address 00:50:2c:00:d5:da
 icsphy0 at vr0 phy 1: ICS1893 10/100 PHY, rev. 1
 isa0 at pcib0
 isadma0 at isa0
 pckbc0 at isa0 port 0x60/5
 pckbd0 at pckbc0 (kbd slot)
 pckbc0: using irq 1 for kbd slot
 wskbd0 at pckbd0: console keyboard, using wsdisplay0
 pmsi0 at pckbc0 (aux slot)
 pckbc0: using irq 12 for aux slot
 wsmouse0 at pmsi0 mux 0
 pcppi0 at isa0 port 0x61
 midi0 at pcppi0: <PC speaker>
 sysbeep0 at pcppi0
 lpt0 at isa0 port 0x378/4 irq 7
 it0 at isa0 port 0x290/8: IT87
 npx0 at isa0 port 0xf0/16: using exception 16
 biomask e35d netmask ef7d ttymask ffff
 pctr: user-level cycle counter enabled
 mtrr: Pentium Pro MTRR support
 dkcsum: wd0 matched BIOS disk 80
 dkcsum: wd1 matched BIOS disk 81
 root on wd0a
 rootdev=0x0 rrootdev=0x300 rawdev=0x302
 OpenBSD 3.6-current (GENERIC) #231: Tue Dec 28 16:58:56 MST 2004
     deraadt_(_at_)_i386_(_dot_)_openbsd_(_dot_)_org:/usr/src/sys/arch/i386/compile/GENERIC
 cpu0: AMD Athlon(tm) XP 1700+ ("AuthenticAMD" 686-class) 1.47 GHz
 cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE
 real mem  = 267952128 (261672K)
 avail mem = 237678592 (232108K)
 using 3296 buffers containing 13500416 bytes (13184K) of memory
 mainbus0 (root)
 bios0 at mainbus0: AT/286+(e3) BIOS, date 01/28/03, BIOS32 rev. 0 @ 0xfb520
 apm0 at bios0: Power Management spec V1.2
 apm0: AC on, battery charge unknown
 pcibios0 at bios0: rev 2.1 @ 0xf0000/0xdf94
 pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfdef0/160 (8 entries)
 pcibios0: PCI Exclusive IRQs: 3 5 10 11
 pcibios0: PCI Interrupt Router at 000:17:0 ("VIA VT8366 ISA" rev 0x00)
 pcibios0: PCI bus #1 is the last bus
 bios0: ROM list: 0xc0000/0x8000 0xc8000/0x8000!
 cpu0 at mainbus0
 pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
 pchb0 at pci0 dev 0 function 0 "VIA VT8366 PCI" rev 0x00
 ppb0 at pci0 dev 1 function 0 "VIA VT8366 AGP" rev 0x00
 pci1 at ppb0 bus 1
 vga1 at pci0 dev 8 function 0 "Matrox MGA Millennium II 2164W" rev 0x00
 wsdisplay0 at vga1: console (80x25, vt100 emulation)
 wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
 dc0 at pci0 dev 9 function 0 "Lite-On PNIC-II" rev 0x25: irq 5, address 00:a0:cc:e0:38:8c
 dcphy0 at dc0 phy 31: internal PHY
 dc1 at pci0 dev 10 function 0 "Lite-On PNIC-II" rev 0x25: irq 10, address 00:a0:cc:e5:85:bf
 dcphy1 at dc1 phy 31: internal PHY
 cmpci0 at pci0 dev 14 function 0 "C-Media Electronics CMI8738/C3DX Audio" rev 0x10: irq 11
 audio0 at cmpci0
 pcib0 at pci0 dev 17 function 0 "VIA VT8366 ISA" rev 0x00
 pciide0 at pci0 dev 17 function 1 "VIA VT82C571 IDE" rev 0x06: ATA100, channel 0 configured to compatibility, channel 1 configured to compatibility
 atapiscsi0 at pciide0 channel 0 drive 0
 scsibus0 at atapiscsi0: 2 targets
 cd0 at scsibus0 targ 0 lun 0: <MITSUMI, CD-ROM FX120T !B, b03> SCSI0 5/cdrom removable
 cd0(pciide0:0:0): using PIO mode 3, DMA mode 1
 wd0 at pciide0 channel 1 drive 0: <Maxtor 6Y200P0>
 wd0: 16-sector PIO, LBA48, 194481MB, 398297088 sectors
 wd1 at pciide0 channel 1 drive 1: <Maxtor 91728D8>
 wd1: 16-sector PIO, LBA, 16479MB, 33750864 sectors
 wd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2
 wd1(pciide0:1:1): using PIO mode 4, Ultra-DMA mode 2
 uhci0 at pci0 dev 17 function 2 "VIA VT83C572 USB" rev 0x1b: irq 3
 usb0 at uhci0: USB revision 1.0
 uhub0 at usb0
 uhub0: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
 uhub0: 2 ports with 2 removable, self powered
 uhci1 at pci0 dev 17 function 3 "VIA VT83C572 USB" rev 0x1b: irq 3
 usb1 at uhci1: USB revision 1.0
 uhub1 at usb1
 uhub1: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
 uhub1: 2 ports with 2 removable, self powered
 uhci2 at pci0 dev 17 function 4 "VIA VT83C572 USB" rev 0x1b: irq 3
 usb2 at uhci2: USB revision 1.0
 uhub2 at usb2
 uhub2: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
 uhub2: 2 ports with 2 removable, self powered
 vr0 at pci0 dev 18 function 0 "VIA RhineII-2" rev 0x70: irq 11 address 00:50:2c:00:d5:da
 icsphy0 at vr0 phy 1: ICS1893 10/100 PHY, rev. 1
 isa0 at pcib0
 isadma0 at isa0
 pckbc0 at isa0 port 0x60/5
 pckbd0 at pckbc0 (kbd slot)
 pckbc0: using irq 1 for kbd slot
 wskbd0 at pckbd0: console keyboard, using wsdisplay0
 pmsi0 at pckbc0 (aux slot)
 pckbc0: using irq 12 for aux slot
 wsmouse0 at pmsi0 mux 0
 pcppi0 at isa0 port 0x61
 midi0 at pcppi0: <PC speaker>
 sysbeep0 at pcppi0
 lpt0 at isa0 port 0x378/4 irq 7
 it0 at isa0 port 0x290/8: IT87
 npx0 at isa0 port 0xf0/16: using exception 16
 biomask e35d netmask ef7d ttymask ffff
 pctr: user-level cycle counter enabled
 mtrr: Pentium Pro MTRR support
 dkcsum: wd0 matched BIOS disk 80
 dkcsum: wd1 matched BIOS disk 81
 root on wd0a
 rootdev=0x0 rrootdev=0x300 rawdev=0x302



Visit your host, monkey.org