[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

ppp - bus error



Hello, I get a strange error with ppp (with pppoe):

bash-2.05b# ppp -nat tdsl
Working in interactive mode
Using interface: tun0
Warning: Add! route failed: 0.0.0.0/0: errno: No such process
Oct 25 00:37:45 bark ppp[31381]: tun0: Warning: Add! route failed: 0.0.0.0/0: errno: No such process
ppp ON bark> dial
Warning: Carrier settings ignored
ppp ON bark> Oct 25 00:38:54 bark ppp[31381]: tun0: Warning: Carrier settings ignored
Warning: deflink: Reducing configured MRU from 1500 to 1492
Oct 25 00:38:55 bark ppp[31381]: tun0: Warning: deflink: Reducing configured MRU from 1500 to 1492
Bus error
bash-2.05b#


bash-2.05b# uname -a
OpenBSD bark.example.net 3.2 GENERIC#36 sparc


From ppp.log :

Oct 25 00:35:33 bark ppp[28396]: tun0: Phase: deflink: closed -> opening
Oct 25 00:35:33 bark ppp[28396]: tun0: Warning: Carrier settings ignored
Oct 25 00:35:33 bark ppp[28396]: tun0: Warning: Carrier settings ignored
Oct 25 00:35:33 bark ppp[28396]: tun0: Phase: deflink: Connected!
Oct 25 00:35:33 bark ppp[28396]: tun0: Phase: deflink: opening -> dial
Oct 25 00:35:33 bark ppp[28396]: tun0: Chat: deflink: Dial attempt 1 of 1
Oct 25 00:35:33 bark ppp[28396]: tun0: Phase: deflink: dial -> carrier
Oct 25 00:35:33 bark ppp[28396]: tun0: Phase: deflink: carrier -> login
Oct 25 00:35:33 bark ppp[28396]: tun0: Phase: deflink: login -> lcp
Oct 25 00:35:33 bark ppp[28396]: tun0: LCP: FSM: Using "deflink" as a transport
Oct 25 00:35:33 bark ppp[28396]: tun0: LCP: deflink: State change Initial --> Closed
Oct 25 00:35:33 bark ppp[28396]: tun0: LCP: deflink: State change Closed --> Stopped
Oct 25 00:35:34 bark ppp[28396]: tun0: LCP: deflink: LayerStart
Oct 25 00:35:34 bark ppp[28396]: tun0: Warning: deflink: Reducing configured MRU from 1500 to 1492
Oct 25 00:35:34 bark ppp[28396]: tun0: Warning: deflink: Reducing configured MRU from 1500 to 1492
Oct 25 00:35:34 bark ppp[28396]: tun0: LCP: deflink: SendConfigReq(1) state = Stopped
Oct 25 00:35:34 bark ppp[28396]: tun0: LCP: MRU[4] 1492
Oct 25 00:35:34 bark ppp[28396]: tun0: LCP: MAGICNUM[6] 0x36351045


This is on SPARC (SS10), I've got the (basically) same configuration working on i386:
OpenBSD shout 3.1 SHOUT#6 i386


but the error about Add! route is there, too. What is this ?

Any ideas ?


This is the config (ppp.conf):


default:
set log Phase Chat LCP IPCP CCP tun command Warning Error Alert
# set redial 15 65535
# set reconnect 15 65535


tdsl:
set device "!/usr/sbin/pppoe -i le1"
set mru max 1492
set mtu max 1492
enable lqr
enable mssfixup
set lqrperiod 5
set cd 5
set dial
set login
set timeout 1800
disable acfcomp protocomp
deny acfcomp
set crtscts off
set speed sync
set authname X*X*X*X*X*X*X
set authkey *X*x*x*x*X*
set ifaddr 10.0.0.1/0 10.0.0.2/0 0.0.0.0 0.0.0.0
delete! default
add! default HISADDR
enable dns



Rainer -- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ Rainer Duffner Munich rainer_(_at_)_ultra-secure_(_dot_)_de Germany http://www.i-duffner.de Freising ======================================== When shall we three meet again In thunder, lightning, or in rain? ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~