[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

XFree86 crashes my openbsd 2.9 in a IBM Aptiva



I'm sorry but my OpenBSD box is not connected to internet, so I can't use sendbug

I've got an IBM Aptiva 2176 with 31M memory with a Cirrus Logic CL-GD5430 PCI with 1M memory. I attach a complete dmesg.
X works fine with 2.8 but not at all with 2.9. I've installed all the basic distribution (2.9) and neither the packages nor the ports.
I use OpenBSD 2.8 and it works fine, but when I tried the 2.9 it seems to work in text mode, but the XFree86 crashes ALL the system not only the X. It happens always. I can't use nor XF86Setup nor startx. XF86cfg also doesn't seem to work. I thought that it could be the XFree86 4.x.x and I tried to install the xbase28, xserver28, xshare28...etc from openbsd 2.8 on a system with the base2.9 but it crashes too.
I'm sorry but I don't know what can I do. It crashes always I try to config with XF86Setup or if I try startx. I can't use X, and I tried the openbsd 2.9 because I want to try other bug which occurs on the 2.8. When 2.9 will work fine then I try it and if it's not solved I'll report it too.


Thank you very much.
OpenBSD 2.8 (GENERIC) #399: Mon Nov  6 10:59:23 MST 2000
    deraadt_(_at_)_i386_(_dot_)_openbsd_(_dot_)_org:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: F00F bug workaround installed
cpu0: Intel Pentium (P54C) ("GenuineIntel" 586-class) 150 MHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,MCE,CX8
real mem  = 33140736 (32364K)
avail mem = 25706496 (25104K)
using 430 buffers containing 1761280 bytes (1720K) of memory
User Kernel Config
UKC> disable pcibios
168 pcibios0 disabled
UKC> quit
Continuing...
mainbus0 (root)
bios0 at mainbus0: AT/286+(84) BIOS, date 02/10/99, BIOS32 rev. 0 @ 0xfd981
apm0 at bios0: Power Management spec V1.2
apm0: AC on, battery charge unknown
pcibios at bios0 function 0x1a not configured
pci0 at mainbus0 bus 0: configuration mode 1 (bios)
pchb0 at pci0 dev 0 function 0 "SIS 5511" rev 0x00
pcib0 at pci0 dev 1 function 0 "SIS 85C503 ISA" rev 0x01
pciide0 at pci0 dev 1 function 1 "SIS 5513 EIDE" rev 0x08: DMA, channel 0 configured to compatibility, channel 1 configured to compatibility
wd0 at pciide0 channel 0 drive 0: <QUANTUM FIREBALL EL2.5A>
wd0: can use 32-bit, PIO mode 4, DMA mode 2
wd0: 16-sector PIO, LBA, 2445MB, 5300 cyl, 15 head, 63 sec, 5008500 sectors
wd1 at pciide0 channel 0 drive 1: <WDC AC2850F>
wd1: can use 32-bit, PIO mode 3, DMA mode 1
wd1: 16-sector PIO, LBA, 814MB, 1654 cyl, 16 head, 63 sec, 1667232 sectors
pciide0: channel 0 interrupting at irq 14
wd0(pciide0:0:0): using PIO mode 4, DMA mode 2 (using DMA data transfers)
wd1(pciide0:0:1): using PIO mode 3, DMA mode 1 (using DMA data transfers)
atapiscsi0 at pciide0 channel 1
scsibus0 at atapiscsi0: 2 targets
pciide0:1:0: IDENTIFY timed out
cd0 at scsibus0 targ 0 lun 0: <HP, CD-Writer+ 7200, 3.01> SCSI0 5/cdrom removable
cd0: can use 32-bit, PIO mode 3, DMA mode 1
pciide0: channel 1 interrupting at irq 15
cd0(pciide0:1:0): using PIO mode 3, DMA mode 1 (using DMA data transfers)
"Cirrus Logic CL-GD5430" rev 0x47 at pci0 dev 12 function 0 not configured
"SIS 86C205" rev 0xd3 at pci0 dev 20 function 0 not configured
isa0 at pcib0
isadma0 at isa0
ne1 at isa0 port 0x300/32 irq 10
ne1: NE2000 (RTL8019) Ethernet
ne1: address 00:00:21:d7:b6:0a
eg0: can't map I/O space
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
sysbeep0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: using exception 16
pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
pccom2 at isa0 port 0x3e8/8 irq 5: ns16550a, 16 byte fifo
vt0 at isa0 port 0x60/16 irq 1: vga 80/132 col, color, 8 scr, mf2-kbd
pms0 at vt0 irq 12
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
isapnp0 at isa0 port 0x279: read port 0x203
wss1 at isapnp0 "CRD4236-1, CSC0000, , WSS/SB" port 0x534/4,0x388/4,0x220/16 irq 5 drq 1,0: CS4236/CS4236B (vers 63)
audio0 at wss1
joy0 at isapnp0 "CRD4236-1, CSC0001, , GAME" port 0x200/8
"CRD4236-1, CSC0010, , CTRL" at isapnp0 port 0x110/8 not configured
mpu0 at isapnp0 "CRD4236-1, CSC0003, , MPU" port 0x330/2 irq 9
mpu0: find failed
biomask c040 netmask c440 ttymask d4c2
pctr: 586-class performance counters and user-level cycle counter enabled
wd0: no disk label
dkcsum: wd0 matched BIOS disk 80
dkcsum: wd1 matched BIOS disk 81
root on wd1a
rootdev=0x10 rrootdev=0x310 rawdev=0x312