[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Giga Byte GS-SR125EDL



Ok,

Well the good news is a pxeboot worked a treat, and we currently have  
it up on 1 CPU.  I'm fetching -current so I can build an  
up-to-the-minute kernel and will report back once this is done  
(possibly tomorrow now considering the time, and pizza is en route :)

If there's any interest ... the dmesg is below (if not, I apologise for  
the use of bandwidth :)

OpenBSD 3.5-current (GENERIC) #141: Mon Jun 14 12:25:01 MDT 2004
     deraadt@i386.openbsd.org:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel(R) Xeon(TM) CPU 2.80GHz ("GenuineIntel" 686-class) 2.80 GHz
cpu0:  
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36, 
CFLUSH,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,CNXT-ID
real mem  = 1073254400 (1048100K)
avail mem = 987570176 (964424K)
using 4278 buffers containing 53764096 bytes (52504K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(01) BIOS, date 10/03/03, BIOS32 rev. 0 @  
0xfd731
apm0 at bios0: Power Management spec V1.2
apm0: AC on, battery charge unknown
pcibios0 at bios0: rev. 2.1 @ 0xfd730/0x8d0
pcibios0: PCI IRQ Routing Table rev. 1.0 @ 0xfdf20/192 (10 entries)
pcibios0: no compatible PCI ICU found: ICU vendor 0xffff product 0xffff
pcibios0: PCI bus #0 is the last bus
bios0: ROM list: 0xc0000/0x8000 0xc8000/0x4000! 0xd0000/0x1a00!  
0xd2000/0x1800 0xd3800/0x1800 0xdf000/0x1000!
cpu0 at mainbus0
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "ServerWorks CMIC_SL Host" rev 0x32
pchb1 at pci0 dev 0 function 1 "ServerWorks CMIC_SL Host" rev 0x00
pci1 at pchb1 bus 1
vga1 at pci0 dev 5 function 0 "ATI Rage XL" rev 0x27
wsdisplay0 at vga1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
pciide0 at pci0 dev 6 function 0 "ITExpress IT8212F" rev 0x10: DMA,  
channel 0 wired to native-PCI, channel 1 wired to native-PCI
pciide0: using irq 7 for native-PCI interrupt
wd0 at pciide0 channel 0 drive 0: <Maxtor 6Y080P0>
wd0: 16-sector PIO, LBA, 78167MB, 160086528 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 6
wd1 at pciide0 channel 1 drive 0: <Maxtor 6Y080P0>
wd1: 16-sector PIO, LBA, 78167MB, 160086528 sectors
wd1(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 6
pcib0 at pci0 dev 15 function 0 "ServerWorks CSB6 PCI" rev 0xa0
pciide1 at pci0 dev 15 function 1 "ServerWorks CSB6 IDE" rev 0xa0: DMA
atapiscsi0 at pciide1 channel 0 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <MITSUMI, CD-ROM SR244W, T01A> SCSI0  
5/cdrom removable
cd0(pciide1:0:0): using PIO mode 4, DMA mode 2, Ultra-DMA mode 2
ohci0 at pci0 dev 15 function 2 "ServerWorks CSB6 USB" rev 0x05: irq 9,  
version 1.0, legacy support
ohci0: SMM does not respond, resetting
usb0 at ohci0: USB revision 1.0
uhub0 at usb0
uhub0: ServerWorks OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 4 ports with 4 removable, self powered
pchb2 at pci0 dev 15 function 3 "ServerWorks CSB6 LPC" rev 0x00
pchb3 at pci0 dev 16 function 0 "ServerWorks CIOB-E" rev 0x12
pchb4 at pci0 dev 16 function 2 "ServerWorks CIOB-E" rev 0x12
pci2 at pchb4 bus 2
bge0 at pci2 dev 0 function 0 "Broadcom BCM5704C" rev 0x02: irq 11:  
address: 00:0d:61:15:6e:0e
brgphy0 at bge0 phy 1: BCM5704 10/100/1000baseTX PHY, rev. 0
bge1 at pci2 dev 0 function 1 "Broadcom BCM5704C" rev 0x02: irq 10:  
address: 00:0d:61:15:6e:0f
brgphy1 at bge1 phy 1: BCM5704 10/100/1000baseTX PHY, rev. 0
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
sysbeep0 at pcppi0
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
biomask f3e5 netmask ffe5 ttymask ffe7
pctr: user-level cycle counter enabled
dkcsum: wd0 matched BIOS disk 80
wd1: no disk label
dkcsum: wd1 matched BIOS disk 81
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302

and bsd.mp

OpenBSD 3.5-current (GENERIC.MP) #2: Mon Jun 14 12:43:47 MDT 2004
     deraadt@i386.openbsd.org:/usr/src/sys/arch/i386/compile/GENERIC.MP
cpu0: Intel(R) Xeon(TM) CPU 2.80GHz ("GenuineIntel" 686-class) 2.80 GHz
cpu0:  
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36, 
CFLUSH,ACPI,MMX,FXSR
real mem  = 1073254400 (1048100K)
avail mem = 987512832 (964368K)
using 4278 buffers containing 53764096 bytes (52504K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(01) BIOS, date 10/03/03, BIOS32 rev. 0 @  
0xfd731
apm0 at bios0: Power Management spec V1.2
apm0: AC on, battery charge unknown
pcibios0 at bios0: rev. 2.1 @ 0xfd730/0x8d0
pcibios0: PCI IRQ Routing Table rev. 1.0 @ 0xfdf20/192 (10 entries)
pcibios0: no compatible PCI ICU found: ICU vendor 0xffff product 0xffff
pcibios0: PCI bus #0 is the last bus
bios0: ROM list: 0xc0000/0x8000 0xc8000/0x4000! 0xd0000/0x1a00!  
0xd2000/0x1800 0xd3800/0x1800 0xdf
mainbus0: scanning 0x9ec00 to 0x9eff0 for MP signature
mainbus0: scanning 0x9e400 to 0x9e7f0 for MP signature
mainbus0: scanning 0xf0000 to 0xffff0 for MP signature
mainbus0: MP floating pointer found in bios at 0xf71a0
mainbus0: MP config table at 0x9f170, 316 bytes long
mainbus0: Intel MP Specification (Version 1.4) (Gigabyte 8EGPDR Pltfm)
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: calibrating local timer
cpu0: apic clock running at 132 MHz
cpu0: kstack at 0xe8229000 for 8192 bytes
cpu0: idle pcb at 0xe8229000, idle sp at 0xe822afa0
cpu1 at mainbus0: apid 6 (application processor)
cpu1: Intel Pentium 4 ("GenuineIntel" 686-class) 2.80 GHz
cpu1:  
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36, 
CFLUSH,ACPI,MMX,FXSR
cpu1: kstack at 0xe822b000 for 8192 bytes
cpu1: idle pcb at 0xe822b000, idle sp at 0xe822cfa0
mainbus0: bus 0 is type PCI
mainbus0: bus 1 is type PCI
mainbus0: bus 2 is type PCI
mainbus0: bus 3 is type ISA
ioapic0 at mainbus0 apid 2: pa 0xfec00000, virtual wire mode, version  
11, 16 pins
ioapic1 at mainbus0 apid 3: pa 0xfec01000, virtual wire mode, version  
11, 16 pins
ioapic2 at mainbus0 apid 4: pa 0xfec02000, virtual wire mode, version  
11, 16 pins
ioapic3 at mainbus0 apid 5: pa 0xfec03000, virtual wire mode, version  
11, 16 pins
ioapic0: int0 attached to ExtINT (type 0x3 flags 0x5)
ioapic0: int1 attached to isa0 irq 1 (type 0x0 flags 0x5)
ioapic0: int2 attached to isa0 irq 0 (type 0x0 flags 0x5)
ioapic0: int3 attached to isa0 irq 3 (type 0x0 flags 0x5)
ioapic0: int4 attached to isa0 irq 4 (type 0x0 flags 0x5)
ioapic0: int5 attached to isa0 irq 5 (type 0x0 flags 0x5)
ioapic0: int6 attached to isa0 irq 6 (type 0x0 flags 0x5)
ioapic0: int7 attached to isa0 irq 7 (type 0x0 flags 0xf)
ioapic0: int8 attached to isa0 irq 8 (type 0x0 flags 0x5)
ioapic0: int9 attached to pci0 device 15 INT_A (type 0x0 flags 0xf)
ioapic0: int10 attached to isa0 irq 10 (type 0x0 flags 0xf)
ioapic0: int11 attached to isa0 irq 11 (type 0x0 flags 0xf)
ioapic0: int12 attached to isa0 irq 12 (type 0x0 flags 0x5)
ioapic0: int13 attached to isa0 irq 13 (type 0x0 flags 0x5)
ioapic0: int14 attached to isa0 irq 14 (type 0x0 flags 0x5)
ioapic0: int15 attached to isa0 irq 15 (type 0x0 flags 0x5)
ioapic1: int3 attached to pci0 device 5 INT_A (type 0x0 flags 0xf)
ioapic1: int14 attached to pci0 device 6 INT_A (type 0x0 flags 0xf)
ioapic0: int9 attached to pci0 device 15 INT_A (type 0x0 flags 0xf)
local apic: int0 attached to ExtINT (type 0x3 flags 0x5)
local apic: int1 attached to NMI (type 0x1 flags 0x5)
mainbus0: MP WARNING: 236 bytes of extended entries not examined
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "ServerWorks CMIC_SL Host" rev 0x32
pchb1 at pci0 dev 0 function 1 "ServerWorks CMIC_SL Host" rev 0x00
pci1 at pchb1 bus 1
vga1 at pci0 dev 5 function 0 "ATI Rage XL" rev 0x27
wsdisplay0 at vga1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
pciide0 at pci0 dev 6 function 0 "ITExpress IT8212F" rev 0x10: DMA,  
channel 0 wired to native-PCI,
pciide0: using apic 3 int 14 (irq 7) for native-PCI interrupt
wd0 at pciide0 channel 0 drive 0: <Maxtor 6Y080P0>
wd0: 16-sector PIO, LBA, 78167MB, 160086528 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 6
wd1 at pciide0 channel 1 drive 0: <Maxtor 6Y080P0>
wd1: 16-sector PIO, LBA, 78167MB, 160086528 sectors
wd1(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 6
pcib0 at pci0 dev 15 function 0 "ServerWorks CSB6 PCI" rev 0xa0
pciide1 at pci0 dev 15 function 1 "ServerWorks CSB6 IDE" rev 0xa0: DMA
atapiscsi0 at pciide1 channel 0 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <MITSUMI, CD-ROM SR244W, T01A> SCSI0  
5/cdrom removable
cd0(pciide1:0:0): using PIO mode 4, DMA mode 2, Ultra-DMA mode 2
ohci0 at pci0 dev 15 function 2 "ServerWorks CSB6 USB" rev 0x05: apic 2  
int 9 (irq 9), version 1.0
ohci0: SMM does not respond, resetting
usb0 at ohci0: USB revision 1.0
uhub0 at usb0
uhub0: ServerWorks OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 4 ports with 4 removable, self powered
pchb2 at pci0 dev 15 function 3 "ServerWorks CSB6 LPC" rev 0x00
pchb3 at pci0 dev 16 function 0 "ServerWorks CIOB-E" rev 0x12
pchb4 at pci0 dev 16 function 2 "ServerWorks CIOB-E" rev 0x12
pci2 at pchb4 bus 2
bge0 at pci2 dev 0 function 0 "Broadcom BCM5704C" rev 0x02: apic 2 int  
11 (irq 11): address: 00:0d
brgphy0 at bge0 phy 1: BCM5704 10/100/1000baseTX PHY, rev. 0
bge1 at pci2 dev 0 function 1 "Broadcom BCM5704C" rev 0x02: apic 2 int  
10 (irq 10): address: 00:0d
brgphy1 at bge1 phy 1: BCM5704 10/100/1000baseTX PHY, rev. 0
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
sysbeep0 at pcppi0
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
biomask 0 netmask 0 ttymask 0
ioapic3: enabling
ioapic3: int0 0x10000 0x0
ioapic3: int1 0x10000 0x0
ioapic3: int2 0x10000 0x0
ioapic3: int3 0x10000 0x0
ioapic3: int4 0x10000 0x0
ioapic3: int5 0x10000 0x0
ioapic3: int6 0x10000 0x0
ioapic3: int7 0x10000 0x0
ioapic3: int8 0x10000 0x0
ioapic3: int9 0x10000 0x0
ioapic3: int10 0x10000 0x0
ioapic3: int11 0x10000 0x0
ioapic3: int12 0x10000 0x0
ioapic3: int13 0x10000 0x0
ioapic3: int14 0x10000 0x0
ioapic3: int15 0x10000 0x0
ioapic2: enabling
ioapic2: int0 0x10000 0x0
ioapic2: int1 0x10000 0x0
ioapic2: int2 0x10000 0x0
ioapic2: int3 0x10000 0x0
ioapic2: int4 0x10000 0x0
ioapic2: int5 0x10000 0x0
ioapic2: int6 0x10000 0x0
ioapic2: int7 0x10000 0x0
ioapic2: int8 0x10000 0x0
ioapic2: int9 0x10000 0x0
ioapic2: int10 0x10000 0x0
ioapic2: int11 0x10000 0x0
ioapic2: int12 0x10000 0x0
ioapic2: int13 0x10000 0x0
ioapic2: int14 0x10000 0x0
ioapic2: int15 0x10000 0x0
ioapic1: enabling
ioapic1: int0 0x10000 0x0
ioapic1: int1 0x10000 0x0
ioapic1: int2 0x10000 0x0
ioapic1: int3 0x1a100 0x0
ioapic1: int4 0x10000 0x0
ioapic1: int5 0x10000 0x0
ioapic1: int6 0x10000 0x0
ioapic1: int7 0x10000 0x0
ioapic1: int8 0x10000 0x0
ioapic1: int9 0x10000 0x0
ioapic1: int10 0x10000 0x0
ioapic1: int11 0x10000 0x0
ioapic1: int12 0x10000 0x0
ioapic1: int13 0x10000 0x0
ioapic1: int14 0xa140 0x0
ioapic1: int15 0x10000 0x0
ioapic0: enabling
ioapic0: int0 0x10700 0x0
ioapic0: int1 0x170 0x0
ioapic0: int2 0x10100 0x0
ioapic0: int3 0x1b0 0x0
ioapic0: int4 0x1b1 0x0
ioapic0: int5 0x10100 0x0
ioapic0: int6 0x141 0x0
ioapic0: int7 0x1a100 0x0
ioapic0: int8 0x10100 0x0
ioapic0: int9 0xa142 0x0
ioapic0: int10 0xa150 0x0
ioapic0: int11 0xa151 0x0
ioapic0: int12 0x10100 0x0
ioapic0: int13 0x10100 0x0
ioapic0: int14 0x143 0x0
ioapic0: int15 0x144 0x0
pctr: user-level cycle counter enabled
dkcsum: wd0 matched BIOS disk 80
wd1: no disk label
dkcsum: wd1 matched BIOS disk 81
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302
WARNING: / was not properly unmounted
apm0: disconnected
cpu1: starting, init idle stack ptr is 0xe822cfa0
cpu1: CPU 6 running
openbsd-1#



On 21 Jun 2004, at 03:54, Nick Holland wrote:

> Jon Morby wrote:
>
>> I've taken both a current snapshot and a release snapshot of 3.5's  
>> boot  CD and tried to boot them on one of the boxes we have here, but  
>> I get  "ERR X" before boot even starts.
>
>> Any suggestions gratefully received!
>
> What is it you are trying to boot the CDs in? (yes, a CDROM drive, but  
> how
> is it attached?)
>
> The ERR X coming from a CD boot is SO unrelated to the day-to-day  
> booting
> of OpenBSD that I would not jump to any conclusions about the  
> compatability
> of OpenBSD and the box based on this (there may be an issue with USB  
> CDROM
> drives and booting OpenBSD).  Just use some other install technique,
> such as floppy, pxeboot, or even moving the drive to another computer  
> to
> get around it.  Once you have a basic OpenBSD install in place, you  
> can then
> do bsd.rd upgrades and reinstalls.
>
> BTW: if you already have this machine in hand as you seem to, DO THIS
> IMMEDIATELY, I don't mean next week, tomorrow at the latest.  This  
> could be
> a really good time to deal with any issues IF there are any with this  
> system.
>
> Nick.
> -- 
> http://www.holland-consulting.net
>
>
Kindest Regards

Jon Morby

fax to email service -  register at http://www.fido.net/fax2email/
and for all your telecom needs - http://www.fidotelecom.com/
-- 
FidoNet Registration Services Ltd                    tel: 08714 333 666
fido.net - the internet made simple!                  fax: 08714 334 000