[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

rst0 hang



Hey all...
        
        Quick question; using a standard install of 2.7, I'm having issues
getting my rst0 to work.  Have tried two different tape drives, both of which
are recognized by the kernel, and appear to configure fine.  When no tape is in
the drive, the kernel appears to recognize this, and gives me errors when I try
to access /dev/rsa0 (for example, issuing 'mt status').  
        However, whenever I put the tape in the drive, and issue an 'mt
status', the drive hangs, and stays in an IO Wait state until I reboot the box.
 Dmesg is below; this happens on both the custom kernel that I built, and
GENERIC.

        Anybody have any ideas?  Can't seem to find anything on the mailing
list archives about it.   I've tried playing with the termination, the card
settings, etc.

                                Mike
        

OpenBSD 2.7 (BACKUP) #0: Wed May 30 18:03:53 UTC 2001
    root@backup:/usr/src/sys/arch/i386/compile/BACKUP
cpu0: Intel Pentium III (Coppermine) ("GenuineIntel" 686-class) 698 MHz
cpu0:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,SYS,MTRR,PGE,MCA,CMOV,PAT,PSE36,SER,MMX,FXSR,
SIMD
real mem  = 132493312 (129388K)
avail mem = 119656448 (116852K)
using 1642 buffers containing 6725632 bytes (6568K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(00) BIOS, date 02/10/00
apm0 at bios0: Power Management spec V1.2
apm0: AC on, battery charge unknown
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "Intel 82810E Memory Controller Hub" rev 0x03:
RNG(6a)
"Intel 82810E Graphics Controller" rev 0x03 at pci0 dev 1 function 0 not
configured
ppb0 at pci0 dev 30 function 0 "Intel 82801AA Hub-to-PCI" rev 0x02
pci1 at ppb0 bus 1
fxp0 at pci1 dev 1 function 0 "Intel 82557" rev 0x08: irq 9, address
00:d0:b7:79:e5:66
inphy0 at fxp0 phy 1: i82555 10/100 media interface, rev. 4
eap0 at pci1 dev 7 function 0 "Ensoniq AudioPCI97" rev 0x06: irq 11
ac97: codec id 0x43525914
ac97: codec features headphone, 20 bit DAC, 18 bit ADC, Spatializer 3D
audio0 at eap0
ahc1 at pci1 dev 9 function 0 "Adaptec(2) AHA-2940U2 Ultra2" rev 0x00: irq 10
ahc1: Wide Channel A, SCSI Id=9, 16/255 SCBs
scsibus0 at ahc1: 16 targets
ahc1: target 1 using 8bit transfers
ahc1: target 1 synchronous at 10.0MHz, offset = 0xf
st0 at scsibus0 targ 1 lun 0: <ARCHIVE, Python 04106-XXX, 7550> SCSI2
1/sequential removable
st0: density code 0x25, 512-byte blocks, write-enabled
pcib0 at pci0 dev 31 function 0 "Intel 82801AA LPC Interface" rev 0x02
pciide0 at pci0 dev 31 function 1 "Intel 82801AA IDE" rev 0x02: DMA, channel 0
wired to compatibility, channel 1 wired to compatibility
wd0 at pciide0 channel 0 drive 0: <IBM-DPTA-372050>
wd0: can use 32-bit, PIO mode 4, DMA mode 2, Ultra-DMA mode 4
wd0: 16-sector PIO, LBA, 19574MB, 16383 cyl, 16 head, 63 sec, 40088160 sectors
pciide0: channel 0 interrupting at irq 14
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2 (using DMA data transfers)
pciide0: channel 1 ignored (disabled)
"Intel 82801AA USB" rev 0x02 at pci0 dev 31 function 2 not configured
"Intel 82801AA SMBus" rev 0x02 at pci0 dev 31 function 3 not configured
isa0 at pcib0
isadma0 at isa0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
sysbeep0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
vt0 at isa0 port 0x60/16 irq 1: vga 80 col, color, 8 scr, mf2-kbd
pms0 at vt0 irq 12
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
biomask 4440 netmask 4640 ttymask 56c2
pctr: 686-class user-level performance counters enabled
mtrr: Pentium Pro MTRR support
dkcsum: wd0 matched BIOS disk 80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302

-- 
______________________________________________________
| Mike Murray                    <mmurray@nCircle.com>
| Scientific Technologist       http://www.nCircle.com
| nCircle Network Security                510.597.2656
| cell - 415.305.0859