[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: USB hang at boot on 2.9



On Wed, 30 May 2001, Damien Miller wrote:

In the grand tradition of replying to one's own email:

> Help -
>
> My compiled-from-cvs 2.9 hangs on boot whenever a USB device is attached.
> The last line printed by the kernel is the ohci initialisation:
>
> ohci0 at pci0 dev 19 function 0 "Compaq USB OpenHost" rev 0x06, OHCI version 1.0, legacy support
>
> I have tried three different USB devices (a 3COM ISDN TA, a Netcomm modem
> and a SMC ethernet NIC) and the hang occurs in all cases.

I forgot to mention that the hang does not occur when the devices are
attached after boot.

The hang seems to occur in the:

OWRITE4(sc, OHCI_RH_STATUS, OHCI_LPSC); /* Enable port power */

macro call in dev/usb/ohci.c:ohci_init(). I have tried adding extra delays,
etc to no avail.

Can anyone help?

-d

-- 
| Damien Miller <djm@mindrot.org> \ ``E-mail attachments are the poor man's
| http://www.mindrot.org          /   distributed filesystem'' - Dan Geer