[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

mounting linux disk images in openbsd



I have a linux partition dumped to a file using dd and i am trying to mount
it in openbsd.  I am running OpenBSD 2.8 Current with vnode support compiled
into my kernel.  I have been using vnconfig to make a device out of the
partition like so:

vnconfig -c -v vnd0 /dump.dd
mount -rv -o noexec,nodev /dev/vnd0c /mnt

The above caused openbsd to lockup and i was forced to reboot.

I then tried 
vnconfig -c -v vnd0 /dump.dd
disklabel -E /dev/vnd0c
made a partition 
mount -rv -o noexec,nodev /dev/vnd0a /mnt

the vnode is created and mounted with no problems but when i try to list the
contents of the partition it is empty.  I have also tried mounting it as a
ufs with the same results.  Im sure there is something small i have over
looked.  I have sowared all over google looking for someone that has done
something like this before with no luck.  If anyone knows what im doing
wrong or if this can even be done please let me know.

Thanks in advance,

Brian