[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Weird NIC behaviour



Hi

I'm having a weird problem with a NIC in an OpenBSD 2.8 router. I have a /30
subnet on one port on a 4way NIC (D-Link 570TX). I have a Linux box
connected at the other end via a crossover cable. This has worked without a
hitch until today when the Linux box lost power. After that I am unable to
connect the to machines again. Config is:

(OpenBSD) de0 
IP:	 	xx.yy.158.9
NETMASK: 	255.255.255.252
BROADCAST:	xx.yy.158.11
NETWORK:	xx.yy.158.8

(Linux) eth1
IP:		xx.yy.158.10
NETMASK:	255.255.255.252
BROADCAST:      xx.yy.158.11
NETWORK:        xx.yy.158.8

>From the OpenBSD box:

ifconfig -a shows:
de0: flags=8863<UP,BROADCAST,NOTRAILERS,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        media: Ethernet autoselect (100baseTX)
        status: active
        inet xx.yy.158.9 netmask 0xfffffffc broadcast
	xx.yy.158.11

netstat -rn shows:
xx.yy.158.8/30     link#3             UC          0        0   1500  de0
xx.yy.158.9        0:80:c8:ca:b8:31   UHL         0    25339   1500  lo0
xx.yy.158.10       0:2:b3:1c:2a:23    UHL         0       10   1500  de0

ping shows:
stone# ping xx.yy.158.10
PING xx.yy.158.10 (xx.yy.158.10): 56 data bytes
ping: sendto: No route to host
ping: wrote xx.yy.158.10 64 chars, ret=-1

I have tried to delete the MAC address in insert it manually. I have taken
the NIC down and up again. I have changed cables. Last a ran a tcpdump on
the OpenBSD box. It shows that pings from the Linux box gets through
(arp lookups). Tcpdump on the Linux box shows no traffic at all. I have
tried to change the mediaopt to full-duplex and it didn't help.

I am at loss here. The way I see everything should work and it used to work
before the poweroutage. If anyone has any ideas on how to fix this or better
an explanation to what is wrong...

Thanx
Sven