[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

mx -> dc didn't got the way it should have



Hey all,

I was trying to get the mx -> dc NIC card issue out of the way so i wouldn't
have to deal with it later.  I figure i could change all mention of "mx0"
and "mx1" to "dc0" and "dc1", reboot with the new kernel and everything
would be fine.  Didn't work that way.  Its real screwy.  it doesn't seem to
recognize the cards right.  heres the ifconfig -a after the reboot.
hosname.dc0 and hostname.dc1 are the same as hostname.mx0 and hostname.mx1
(the relavant parts anyway):

lo0: flags=8009<UP,LOOPBACK,MULTICAST>
        inet6 fe80::1@lo0 prefixlen 64 scopeid 0x4
        inet6 ::1 prefixlen 128
        inet 127.0.0.1 netmask 0xff000000
lo1: flags=8008<LOOPBACK,MULTICAST>
dc0: flags=8802<BROADCAST,SIMPLEX,MULTICAST>
        media: Ethernet none (none)
dc1: flags=8802<BROADCAST,SIMPLEX,MULTICAST>
        media: Ethernet none (none)

heres the dmesg of it at dc, followed by the working kernel with mx enabled:

Broken TRICO kernel with no mx, dc is enabled:
bootargv: diskinfo 0xe03e300c cksumlen 1 memmap 0xe03e3088 apminfo
0xe03e3148
OpenBSD 2.6-current (TRICO) #1: Wed Jan 12 14:36:15 EST 2000
    root@fish:/usr/src/sys/arch/i386/compile/TRICO
cpu0: Intel Pentium III ("GenuineIntel" 686-class, 512KB L2 cache) 499 MHz
cpu0:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,SYS,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,
SIMD
BIOS mem  = 653312 conventional, 133159936 extended
real mem  = 133816320
avail mem = 121311232
using 1659 buffers containing 6795264 bytes of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(1b) BIOS, date 09/21/99
apm0 at bios0: Power Management spec V1.1
apm0: AC on, no battery
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "Intel 82443BX PCI-AGP (PAC)" rev 0x03
ppb0 at pci0 dev 1 function 0 "Intel 82443BX AGP (PAC)" rev 0x03
pci1 at ppb0 bus 1
"ATI Technologies Rage Pro" rev 0x5c at pci1 dev 0 function 0 not configured
pcib0 at pci0 dev 7 function 0 "Intel 82371AB PIIX4 ISA" rev 0x02
pciide0 at pci0 dev 7 function 1 "Intel 82371AB IDE (PIIX4)" rev 0x01: DMA,
channel 0 wired to compatibil
ity, channel 1 wired to compatibility
wd0 at pciide0 channel 0 drive 0: <WDC WD136AA>
wd0: can use 32-bit, PIO mode 4, DMA mode 2, Ultra-DMA mode 2
wd0: 16-sector PIO, LBA, 12971MB, 16383 cyl, 16 head, 63 sec, 26564832
sectors
pciide0: channel 0 interrupting at irq 14
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2 (using DMA data
transfers)
atapiscsi0 at pciide0 channel 1
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <LG, CD-ROM CRD-8480C, 1.04> SCSI0 5/cdrom
removable
cd0: can use 32-bit, PIO mode 4, DMA mode 2, Ultra-DMA mode 2
pciide0: channel 1 interrupting at irq 15
cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2 (using DMA data
transfers)
"Intel 82371AB USB (PIIX4)" rev 0x01 at pci0 dev 7 function 2 not configured
"Intel 82371AB Power Management (PIIX4)" rev 0x02 at pci0 dev 7 function 3
not configured
dc0 at pci0 dev 14 function 0 "Lite-On PNIC-II" rev 0x25: irq 11 address
00:a0:cc:68:64:53
OUI 0x040440 model 0x0001 rev 9 at dc0 phy 31 not configured
dc1 at pci0 dev 15 function 0 "Lite-On PNIC-II" rev 0x25: irq 10 address
00:a0:cc:67:fe:c1
OUI 0x040440 model 0x0001 rev 9 at dc1 phy 31 not configured
isa0 at pcib0
isadma0 at isa0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
sysbeep0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
vt0 at isa0 port 0x60/16 irq 1: vga 80 col, color, 8 scr, mf2-kbd
pms0 at vt0 irq 12
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
biomask c040 netmask cc40 ttymask dcc2
pctr: 686-class user-level performance counters enabled
mtrr: Pentium Pro MTRR support
dc0: supplying EUI64: 00:a0:cc:ff:fe:68:64:53
dkcsum: wd0 matched BIOS disk 80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302
IP Filter: initialized.  Default = pass all, Logging = enabled
IP Filter: v3.3.6





Working TROUT kernel with mx enabled:

bootargv: diskinfo 0xe03fd00c cksumlen 1 memmap 0xe03fd088 apminfo
0xe03fd148
OpenBSD 2.6-current (TROUT) #0: Wed Jan  5 14:00:53 EST 2000
    root@fish:/usr/src/sys/arch/i386/compile/TROUT
cpu0: Intel Pentium III ("GenuineIntel" 686-class, 512KB L2 cache) 499 MHz
cpu0:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,SYS,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,
SIMD
BIOS mem  = 653312 conventional, 133159936 extended
real mem  = 133816320
avail mem = 121204736
using 1659 buffers containing 6795264 bytes of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(1b) BIOS, date 09/21/99
apm0 at bios0: Power Management spec V1.1
apm0: AC on, no battery
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "Intel 82443BX PCI-AGP (PAC)" rev 0x03
ppb0 at pci0 dev 1 function 0 "Intel 82443BX AGP (PAC)" rev 0x03
pci1 at ppb0 bus 1
"ATI Technologies Rage Pro" rev 0x5c at pci1 dev 0 function 0 not configured
pcib0 at pci0 dev 7 function 0 "Intel 82371AB PIIX4 ISA" rev 0x02
pciide0 at pci0 dev 7 function 1 "Intel 82371AB IDE (PIIX4)" rev 0x01: DMA,
channel 0 wired to compatibil
ity, channel 1 wired to compatibility
wd0 at pciide0 channel 0 drive 0: <WDC WD136AA>
wd0: can use 32-bit, PIO mode 4, DMA mode 2, Ultra-DMA mode 2
wd0: 16-sector PIO, LBA, 12971MB, 16383 cyl, 16 head, 63 sec, 26564832
sectors
pciide0: channel 0 interrupting at irq 14
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2 (using DMA data
transfers)
atapiscsi0 at pciide0 channel 1
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <LG, CD-ROM CRD-8480C, 1.04> SCSI0 5/cdrom
removable
cd0: can use 32-bit, PIO mode 4, DMA mode 2, Ultra-DMA mode 2
pciide0: channel 1 interrupting at irq 15
cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2 (using DMA data
transfers)
"Intel 82371AB USB (PIIX4)" rev 0x01 at pci0 dev 7 function 2 not configured
"Intel 82371AB Power Management (PIIX4)" rev 0x02 at pci0 dev 7 function 3
not configured
mx0 at pci0 dev 14 function 0 "Lite-On PNIC-II" rev 0x25: irq 11 address
00:a0:cc:68:64:53
mx0: autoneg complete, link status good (full-duplex, 100Mbps)
mx1 at pci0 dev 15 function 0 "Lite-On PNIC-II" rev 0x25: irq 10 address
00:a0:cc:67:fe:c1
mx1: autoneg complete, link status good (half-duplex, 100Mbps)
isa0 at pcib0
isadma0 at isa0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
sysbeep0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
vt0 at isa0 port 0x60/16 irq 1: vga 80 col, color, 8 scr, mf2-kbd
pms0 at vt0 irq 12
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
biomask c040 netmask cc40 ttymask dcc2
pctr: 686-class user-level performance counters enabled
mtrr: Pentium Pro MTRR support
dkcsum: wd0 matched BIOS disk 80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302
IP Filter: initialized.  Default = pass all, Logging = enabled
IP Filter: v3.3.6
mx0: selecting NWAY, 100Mbps, half duplex