[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: New Tulip driver does not work



On Fri, Jan 07, 2000 at 10:18:30PM -0600, Data Avenue, Inc. wrote:
> Jason,
> 
> I was using the old mx0 driver with 2.6 and it worked great (someone did
> a good job on it).
> In the new kernel (GENERIC), the support for mx0 has been replaced by
> dc0 (tulip). I recompiled my kernel
> for GENERIC w/ yesterday's tree (using tulip ) and suddenly nothing
> worked any more. I did not comment any drivers out (it worked as a tulip
> under Linux (not not me .. my wife) and worked fine). Here are some
> messages from the boot log :
> 
Ok, this should be fixed now.  I hadn't tested with a 98715 (bad me), but
with the addition of dcphy, media selection and operation seem to be
working again.  Automatic media handling doesn't seem to be working
completely right, but I'll be looing into that.

I'm currently building over nfs with:
[...]
dc0 at pci0 dev 8 function 0 "Macronix PMAC 98715" rev 0x20: irq 10 address 00:80:ad:3a:00:c6
dcphy0 at dc0 phy 31: internal PHY
[...]

--Jason Wright