[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

apc-upsd snag with APC Back-UPS ES 500



Hi.

I just purchased an APC Back-UPS ES 500 (Model: BE500) and have my OBSD
machine hooked up to it through the first COM port.  The COM port is
functional and no errors occr when the app is run.  However, the
machine doesn't halt as it should when the power is interrupted (after
the wait time).  Any ideas on how I can get this working are greatly
appreciated.  I searched the archives but didn't find much on this
topic.

Here is the /etc/apc-upsd.conf file I'm using...  I've tested virtually
every combination of options (startuptest, smartmode, ...) on and off
with no success in terms of seeing the machine power down automatically
and cleanly when there is a power failure.  It seems that perhaps there
is no communication between the PC and the UPS?  Also, if it matters,
my UPS came with a black cable.  Is this program compatible with all
APC UPS models?

Thanks for any tips/help!

  Dave

#
#       apc-upsd.conf
#

# ups is connected to ...
# OpenBSD ... device /dev/tty00

#device /dev/tty00
device /dev/cua00

#
# startuptest sends a 'test' sequence to the smart series
#

#startuptest    ON
startuptest     OFF

# debug ON|OFF
#
# OFF ... normal operation
# ON .... don't start as daemon, do tests in smart mode

#debugmode OFF
debugmode ON

# smartmode 
# ON ...... APC Smart-UPS with black cable
# OFF ..... APC BackUPS with gray cable

smartmode ON
#smartmode OFF

#
# extendedsmart 
#
# gives temperature info etc ..
#

extendedsmart ON
#extendedsmart OFF

# time till shutdown in seconds

time 15

# execute this at shutdown time 

execute /sbin/halt

# pidfile 

pidfile /var/run/upsd.pid

# every (n) seconds output information from the ups
# to syslog

#infotime 3600
infotime 30

__________________________________________________
Do You Yahoo!?
Make international calls for as low as $.04/minute with Yahoo! Messenger
http://phonecard.yahoo.com/