[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: new bsd.port.mk



If your ports tree is not in /usr/ports then you *must* set the PORTSDIR
variable to point to wherever it's rooted.

// Brad

brad@comstyle.com
brad@openbsd.org

>Ah hem.
>I updated my ports tree yesterday.
>I keep my ports tree on a separate HDD: /emp/ports
>In the past, this has worked fine. All ports look for depends in the
>correct place and retrieve them properly. No worries.
>
>I've tried to test two ports since I updated my tree and they both
>crap out with messages similar to:
>
>===>  Verifying install for SDL. in devel/sdl
>/bin/sh: cd: /usr/ports/devel/sdl - No such file or directory
>*** Error code 1
>
>(I don't have sdl installed)(this is a dependency of the port I'm
>trying to install)
>
>what I need to know is that because my ports tree is not under /usr?
>or is that a problem with the port?
>
>It seems to me that it is probably a problem with the ports, but
>since I get it twice in a row when I've never gotten a similar
>problem before it makes me uncertain.??
><-->Later . . . 'liam