[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: postgres, DBI and PQconnectdb problem



Depends which packages you installed. PostgreSQL went through a major
change just prior to the release of 2.9 and you may have been caught
with a version of DBI that was created using the older port. Which
packages have you installed from ?

rgds,
--
Peter Galbavy
Knowtion Ltd.
----- Original Message -----
From: "Tor Roberts" <tor@econsci.net>
To: <ports@openbsd.org>
Sent: Saturday, August 11, 2001 1:46 AM
Subject: postgres, DBI and PQconnectdb problem


> Hi,
> I am having a problem getting perl, the DBI and Postgres ports to work
> properly. Whenever I run a perl script that uses DBI I get the error
> message:
> /usr/libexec/ld.so: Undefined symbol "_PQconnectdb" called from
> perl:/usr/local/libdata/perl5/site_perl/i386-openbsd/auto/DBD/Pg/Pg.so
at
> 0x401bf470
>
> I have added shlib_dirs="/usr/local/lib" to rc.local, so it should be
> loading libraries right. I know the scrips work, because I am moving
them
> from another machine where they do work. I assume that the problem
lies in
> the postgres or DBI port. I am running OBSD 2.9. Any help would be
> appreciated.
> Thanks,
>
> -Tor
>
>
>