[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: kdelibs-1.1.2 on OpenBSD



Edit that particular makefile and add the -fsquangle
option next to the -O2 compile option and it'll compile
(at least that worked for me)

------Original Message------
From: John Kerbawy <john@betek.com>
To: <misc@openbsd.org>
Sent: September 25, 1999 4:56:47 AM GMT
Subject: kdelibs-1.1.2 on OpenBSD


Hello. I figured I'd try here before I send in a bug report. (I already
tried the KDE lists).

When I try and compile the latest libs for KDE, I get the following error:

Making all in kab
gmake[2]: Entering directory /usr/ports/x11/kde/libs/work/kdelibs-1.1.2/kab'
/bin/sh ../libtool --silent --mode=compile eg++ -DHAVE_CONFIG_H -I. -I. -I..
-I../kdecore -I../kdeui -I../kfile -I../kfmlib -I/usr/X11R6/include/X11/qt
-I/usr/X11R6/include    -O2    -c addressbook.cc
addressbook.cc: In method ool AddressBook::nameOfField(const class string
&, class string &)':
addressbook.cc:1238: virtual memory exhausted
gmake[2]: *** [addressbook.lo] Error 1
gmake[2]: Leaving directory /usr/ports/x11/kde/libs/work/kdelibs-1.1.2/kab'

This happens on 2 different boxes, both running OpenBSD 2.5.

One is a Celeron 366 (Not Overclocked), 128Mb ECC SDRAM, Quantum IDE
Drive (64Mb Swap).

The other is a Pentium II 300, 64Mb SDRAM, Seagate SCSI Drive (64Mb Swap)

{root}[pornstar:/usr/ports/x11/kde]# gcc -v
Reading specs from /usr/lib/gcc-lib/i386-unknown-openbsd2.5/2.8.1/specs
gcc version 2.8.1

{root}[pornstar:/usr/ports/x11/kde]# eg++ -v
Reading specs from
/usr/local/lib/gcc-lib/i386-unknown-openbsd2.5/egcs-2.91.66/specs
gcc version egcs-2.91.66 19990314 (egcs-1.1.2 release)

I believe that this port requires eg++ for some reason.

On both boxes, if I do a 'ulimit -d -S 65535', I get SIG11's at the same
point. I'm positive my hardware is good.

Here is what my box looks like idling right now:

Memory: Real: 1068K/20M act/tot  Free: 36M  Swap: 920K/63M used/tot

This is basically the same as it looks when it's compiling.. (The box with
128mb of RAM show around 80M free.)

Anyways, if anyone has ideas or a fix for this, please let me know.
Thanks.

--
..j0hn [john@maKintosh.com]

__________________________________________________
FREE Email for ALL! Sign up at http://www.mail.com