[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Building from CVS



On Wed, 15 Sep 1999, Matthew Gregan wrote:

> Hi everyone.
> 
> I just update my /usr/src tree to the current CVS (as of a few hours
> ago). I'm using the .au anoncvs server...
> 
> Once I've updated the tree, I run 'make obj', and it fails in lib/libkvm
> with an error at line 30, something about a bad comparison. I had a
> quick look at the makefile, and I can't see anything wrong (not that I
> know much about makefile syntax).

You have to make sure that /usr/share/mk is up to date. This can be done
by 

# (cd /usr/src/share/mk; make install)

If you look at the build target in /usr/src/Makefile you will find that
this is one of the first thing done...
 
> If I use make -k obj, it also fails somewhere else in the tree with the
> same error (I don't remember where right now, I can check if it's
> important).
> 
> Anyway, is this happening because I'm doing something wrong, or some of
> my tools are out of date? I haven't found much documentation on what to
> do after updating with CVS, and I'm fairly new to all of this.

It isn't easy to document since it's depends on from what you are
upgrading. If you are trying to upgrade from 2.5 you have to upgrade gcc.
This has been documented. You have to look at the mail archive to find
what to do.

What I should do is to take a snapshot and install. This will save you the
hassle of upgrading to current. When you are current it will be easier to 
stay current by following the mailing lists.


> Thanks.
> -- 
> [ Matthew Gregan ]       [ GPG ID: B63A1E95 ]       [ kinetik@ihug.co.nz ]
> [ GPG fingerprint:    FB83 2911 F170 B31C 9E4A  E382 CA8A A2F6 B63A 1E95 ]
> 
-moj