[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Sparc: xlock and keyboard



Hi all!

I ran xlock on a Sun ELC running OpenBSD 2.5 the other day and was
rather surprised to find it stop working (i.e. no xlock anymore, access to
my x-session without having to enter a password!) after a few minutes with
the following message in xconsole:

Access control list restored.
xlock: caught signal 11 while running goop mode (uid 0).

This is probably a configuration issue, but I did not find anything on
this topic (at least I did not understand what I found). I was logged in
as root.

Another question concerning the keyboard. My ELC has a german keyboard and
most keys work fine but not the key with "<", ">" and "|" on it. Is there
a way to get this key working (it is rather neccessary as you all know).

cheers,

Nikolay

PS: I tried to compile the idea code out of Bruce Schneier's "Applied
Crypto" (gcc -shared -fPIC -O2 -o idea idea.c) and got the error message:
"ld: No reference to __DYNAMIC". Any ideas how to get rid of this one?

-- 
PGP: 2048/BEDC92A1     5D 71 64 79 6C EA 7D 51 4E E7 37 CE 4F 1A 39 26
GPG: 1024D/7825D431  1FBD 4D68 6450 C390 CA04 E4EE 3908 77E1 7825 D431
              Wake up and piss, the world is on fire!