[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Problem]: OpenBSD 2.4/2.5 Hangs while booting



I had a dissimilar, but related, problem with OpenBSD 2.5: it started &
operated fine, but would only allow very sporadic throughput on a generic
ne2000 (a PCI version, though, based on the RealTek 8029 chip).  I
replaced it with a DEC-based SMC card (or pair of them, actually), and
everything works beautifully.  Moral of the story:  OpenBSD really doesn't
like ne2000 cards.  Therefore I suggest you get some other kind; last time
I was by the parts store they had some old Intel ISA cards for seven
bucks.

JRM


On Thu, 9 Sep 1999, Vaibhav Goel wrote:

> Date: Thu, 9 Sep 1999 14:00:33 -0700 (PDT)
> From: Vaibhav Goel <vg@overload309.com>
> To: misc@openbsd.org
> Subject: [Problem]: OpenBSD 2.4/2.5 Hangs while booting
> 
> Greetings all;
> 
> First of all, please let me introduce myself.  I am a new (soon to be I
> hope) OpenBSD user.  I have the OpenBSD 2.4 CD.  I am currently running
> Debian GNU/Linux 2.1r2 and would like to venture into the OpenBSD world
> mostly for personal knowledge and the security aspects of it sound
> interesting to delve into.
> 
> Like I mentioned, I have an OpenBSD 2.4 CD from which I tried installing
> yesterday on a generic homebuilt Pentium 100 with 64 Megs RAM, ATI Mach64
> video card, IDE drive(s) ...ie pretty standard PC hardware.  I also have
> an old ISA non-plug-n-pray NE2000 card.  
> 
> The OpenBSD 2.4 install went just fine and when I tried booting off the
> hard disk, it hung during the boot process (I think the kernel probes the
> harddrives and then reaches out to probe the NE2000 card in this cenario).
> In any case, with the 2.4 install the system seemed to hang right after
> the wd2 init phase (i have wd0, wd1 and wd2 on this system).  Please note
> that the NE2000 card was found just fine by the kernel on floppy25.fs and
> I was even able to obtain an IP address from my DHCP server.  BTW, this
> card is on IRQ10 just as an aside.
> 
> I removed the card from the box, and OpenBSD booted just fine.  
> 
> I thought to myself, hmm maybe I should try the 2.5 install.  So off I
> went to my Linux box, and dd'ed myself a fresh new 2.5 floppy and started
> installing via DHCP on the Pentium.  As usual, install went just great but
> this time the system _gets_past_ the wd2 phase (as I mentioned above) but
> still hangs when/after trying to probe/initialize the NE2000 card.  It
> seems to find it and gets the IRQ and MAC address.  After this, the 3.5"
> floppy drive light goes on and stays on till I reset the system.
> 
> Now the funny part which I could not figure out:  I thought this was your
> run-of-the-mill IRQ conflict but I do not have any other devices using IRQ
> 10.  I also removed my card and changed the jumpers to IRQ5 and IRQ12 but
> OpenBSD still says the card is on IRQ10.  Which leads me to believe, that
> there could be a specific kernel parameter which is probing for a card on
> that IRQ.  When I remove the card from the system,  OpenBSD boots in just
> fine.  
> 
> I would greatly appreciate any ideas that you might have to solve this
> problem.  Please note that I am coming from the Linux world and apparently
> things are  a bit different with OpenBSD but any pointers to solving this
> problem will be highly appreciated.
> 
> 
> Thanks in advance,
> 
> Regards,
> 
> VG
> 
> ---
> < Vaibhav Goel > -- < vg@overload309.com > -- < http://www.overload309.com/vg >
> < "Take control of the machine now!" -- Utah Saints >
>