[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Second IEE16 causes system hang when ifconfig run



Hi, all,

After months of working great with a single EtherExpress 16 running, I
added a second EE16 to the box, and likewise recompiled the kernel to
support the second one.  It's recognized correctly on boot, and the
first card configures fine through the standard hostname.ie1 method.
However, when I tried to configure the second card using the same
method, it hung when I ran
# ifconfig ie0 inet xxx.xxx.xxx.xxx broadcast xxx.xxx.xxx.xxx netmask
xxx.xxx.xxx.xxx.
Hung as in system completely hangs and becomes unresponsive to anything
except the reset button or a cold boot.

I'd include the relavent config files, but I don't even know where to
begin debugging for this problem -- even at the level of "Is it hardware
or software?"  The two cards are configured as follows:
ie0 - irq 10 io 300 iomem D4000-DBFFF
ie1 - irq 5  io 240 iomem CC000-C3FFF

I know that the ie0 card works, because it's actually the original, and
ie1 is the added one.  My guesses at this point are anything from bum
ram to a glitch in the ie interface driver, so any help would be
appreciated.

Thanks,
Michael