[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

please help with xserver for 2.9



1. steps to reproduce problem: Just download the 2.9 /i386 files from ftp.openbsd.org, create a boot floppy via- rawrite (floppy29.fs) boot and install all. I did choose yes, that i did intend to run xserver. No packages were added just the base system with X. Reboot. Login as root and cd / , cd usr, cd X11R6, cd bin. When in the usr/X11R6/bin dir. type XF86cfg. The configuration tools comes up. I then configured my screen0 for card0 @ 600*800 . I then select my card ( i have two different machines and both produce the same error ) trident or elsa depending on machine with the correct driver. I then choose my monitor type vga. After all this i choose the quit button and the system pops up a dialog box with the following statement. XF86Config ( write config. to /root/XF86Config.new & lib/X11/xkb/X0-config.keyboard ) i choose yes to both. I am then dumped into a shell with the following comments from the Xserver:
 
could not init font path element /usr/X11R6/lib/X11/fonts/Speedo/ , removing from list!
the next line is the same except /Speedo is Type1.
loader running on openbsd :)
X connection to :8.0 broken (explicit kill or server shutdown)
 
Every time i run xf86cfg and setup everthing then choose to save it it dumps me back to the shell with the same above error.
 
Ok even with the above error i still have tried to (startx) The following is the error from this command.
 
# startx
XFree86 Version 4.0.3 / X Window System etc......
 
error messages:
 
(= =) Log file: "/var/log/XFree86.0.log",
(EE) Unable to locate/open config file
(EE) Error from xf86HandleConfigFile( )
 
Fatal server error:
no screens found
 
X connection to :0.0 broken (explicit kill or server shutdown)
 
I have re-run the xf86cfg tool several times with the same results and now i am asking for help.
 
I saw the errata about a x problem but it was for the XF86Setup and not xf86cfg and a patch was applied to the patch tree for 2.9. I needed to sync my tree anyways so here is the following i have done so far.
 
setenv CVSROOT anoncvs@anoncvs1.ca.openbsd.org:/cvs
cd /usr; cvs checkout -P -rOPENBSD_2_9
 
recompile my kernel save copy as bsd.old and boot with new kernel
after reboot with new kernel i recompiled the binaries as instructed.
reboot
try to configure the xserver again with same results.
 
I have also downloaded the 6-19/20 snapshot and the x server does work and the xf86cfg tool is slightly different. The problem with the snapshot is that any packages added after base install does not work because of lib. problems. Every package added gives the lib26.2 error.
/usr/libexec/ld.so: xxx: libc.so.26.2: No such file or directory.
 
for example i added package joe-the editor and rebooted
at the root type joe # joe      and the above error is given. the same error is given with every package added. this i why i decided to install the General Release 2.9 but now i am having X-problems.
 
System information.
1. compaq ap400 with 6gig ide hd, elsa synergy video card, 128 ram, pent.II 450 mhz.
2. home built, 17gig ide hd, 512 ram, amd-k6-550 mhz, trident 8660 video card.
 
both systems install the OpenBsd code fine and run like a champ except the problems listed above.
 
Now the logs requested:
This is the Xserver log in var.
(
XFree86 Version 4.0.3 / X Window System
(protocol Version 11, revision 0, vendor release 6400)
Release Date: 16 March 2001
 If the server is older than 6-12 months, or if your card is
 newer than the above date, look for a newer version before
 reporting problems.  (See http://www.XFree86.Org/FAQ)
Operating System: OpenBSD 2.9 i386
Module Loader present
(==) Log file: "/var/log/XFree86.0.log", Time: Mon Jun 25 06:11:35 2001
(EE) Unable to locate/open config file
(EE) Error from xf86HandleConfigFile()
Fatal server error:
no screens found
When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to xfree86@xfree86.org.  )
 
here is the dmesg output
(
 
dmesg
OpenBSD 2.9-stable (GENERIC) #0: Sun Jun 24 12:53:58 CDT 2001
    root@test:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: AMD K6-2 ("AuthenticAMD" 586-class) 501 MHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,MCE,CX8,PGE,MMX
real mem  = 268021760 (261740K)
avail mem = 243597312 (237888K)
using 3297 buffers containing 13504512 bytes (13188K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(7b) BIOS, date 01/07/99, BIOS32 rev. 0 @ 0xfb260
apm0 at bios0: Power Management spec V1.2
apm0: AC on, battery charge unknown
pcibios0 at bios0: rev. 2.1 @ 0xf0000/0xb6d8
pcibios0: PCI IRQ Routing Table rev. 1.0 @ 0xfdd30/128 (6 entries)
pcibios0: bad IRQ table checksum
pcibios0: PCI BIOS has 6 Interrupt Routing table entries
pcibios0: PCI Exclusive IRQs: 5 9 10 11
pcibios0: PCI bus #1 is the last bus
bios0: ROM list: 0xc0! 000/0xc000
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "VIA VT82C597 Host-PCI" rev 0x04
ppb0 at pci0 dev 1 function 0 "VIA VT82C598 PCI-AGP" rev 0x00
pci1 at ppb0 bus 1
vga1 at pci1 dev 0 function 0 "Trident 3DImage 9750" rev 0xf3
wsdisplay0 at vga1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
pcib0 at pci0 dev 7 function 0 "VIA VT82C586 PCI-ISA" rev 0x47
pciide0 at pci0 dev 7 function 1 "VIA VT82C571 IDE" rev 0x06: DMA, channel 0 configured to compatibility, channel 1 configured to compatibility
atapiscsi0 at pciide0 channel 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 1 lun 0: <E-IDE, CD-ROM 48X/AKU, T31> SCSI0 5/cdrom removable
wd0 at pciide0 channel 0 drive 0: <WDC WD172AA>
wd0: 16-sector PIO, LBA, 16448MB, 16383 cyl, 16 head, 63 sec, 33687360 sectors
pciide0: channel 0 interrupting at irq 14
wd0(pciide0:0:0): using ! PIO mode 4, DMA mode 2
cd0(pciide0:0:1): using PIO mode 4, DMA mode 2
wd1 at pciide0 channel 1 drive 0: <Maxtor 7245 AT>
wd1: 32-sector PIO, CHS, 234MB, 967 cyl, 16 head, 31 sec, 479632 sectors
pciide0: channel 1 interrupting at irq 15
wd1(pciide0:1:0): using PIO mode 0
"VIA VT82C586 Power Management" rev 0x10 at pci0 dev 7 function 3 not configured
dc0 at pci0 dev 10 function 0 "Lite-On PNIC" rev 0x20: irq 10 address 00:a0:cc:40:f0:26
bmtphy0 at dc0 phy 1: BCM5201 10/100 media interface, rev. 2
dc1 at pci0 dev 11 function 0 "Lite-On PNIC" rev 0x20: irq 5 address 00:a0:cc:40:aa:e1
bmtphy1 at dc1 phy 1: BCM5201 10/100 media interface, rev. 2
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pmsi0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pmsi0 mux 0
pcppi0 at isa0 por! t 0x61
midi0 at pcppi0: <PC speaker>
sysbeep0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
biomask c040 netmask c460 ttymask d4e2
pctr: user-level cycle counter enabled
mtrr: K6-family MTRR support (2 registers)
dkcsum: wd0 matched BIOS disk 80
dkcsum: wd1 matched BIOS disk 81
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302  )
 
please advise.
 
I just wanted to say thanks to the developers for all the hard work as OpenBsd is a Superior O.S.   Thanks Gents / Ladies
 
 
 


Get your FREE download of MSN Explorer at http://explorer.msn.com