[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

2.9 xl0 problem



Hi, I just upgraded a box from 2.8 to 2.9, and the xl0 interface
ceased functioning.

The box: ASUS CUV4X, Celeron 566, 128MB, 3Com 3C905B-TX running
100baseTX-full duplex.  It's worked fine on 2.6, 2.7, 2.8 (ran
apache etc.).  It works fine booting from the cd for 2.9 to the shell.

But it gives "xl0 watchdog timeout" alerts on the console in the
installed version (both upgrade and full clean install), and the
network is not reachable.  Since it's got no network I can't mail
from it directly...

I tried giving it the same IP as another box (another xl0 on 2.8),
and both boxes noticed the IP conflict.  So it's not completely
dead.  But putting on an open IP address nothing could ping it,
and it could ping nothing beyond itself.

If I can provide any more information, please contact me.

Ted Bardusch
OBSDFan@bjmoose.com


Below is the dmesg output (transferred via floppy):

OpenBSD 2.9 (GENERIC) #653: Sat Apr 28 13:57:59 MDT 2001
    deraadt@i386.openbsd.org:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel Pentium III (Coppermine) ("GenuineIntel" 686-class, 128KB L2
cache) 568 MHz
cpu0:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,SYS,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,
SIMD
real mem  = 133787648 (130652K)
avail mem = 119132160 (116340K)
using 1658 buffers containing 6791168 bytes (6632K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(18) BIOS, date 05/17/00, BIOS32 rev. 0 @ 0xf0690
apm0 at bios0: Power Management spec V1.2 (BIOS mgmt disabled)
apm0: AC on, battery charge unknown
pcibios0 at bios0: rev. 2.1 @ 0xf0000/0xf02
pcibios0: PCI IRQ Routing Table rev. 1.0 @ 0xf0e60/160 (8 entries)
pcibios0: PCI Interrupt Router at 000:04:0 ("VIA VT82C686A PCI-ISA" rev
0x00)
pcibios0: PCI bus #1 is the last bus
bios0: ROM list: 0xc0000/0x8000
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "VIA VT8605 Host-PCI" rev 0x81
ppb0 at pci0 dev 1 function 0 "VIA VT8605 PCI-AGP" rev 0x00
pci1 at ppb0 bus 1
pcib0 at pci0 dev 4 function 0 "VIA VT82C686A PCI-ISA" rev 0x22
pciide0 at pci0 dev 4 function 1 "VIA VT82C571 IDE" rev 0x10: DMA, channel 0
configured to compatibility, channel 1 configured to compatibility
pciide0: Ultra/66 capable
wd0 at pciide0 channel 0 drive 0: <Maxtor 54098U8>
wd0: 16-sector PIO, LBA, 39082MB, 16383 cyl, 16 head, 63 sec, 80041248
sectors
pciide0: channel 0 interrupting at irq 14
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 4
atapiscsi0 at pciide0 channel 1
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <E-IDE, CD-ROM 48X/TKU, T41> SCSI0 5/cdrom
removable
pciide0: channel 1 interrupting at irq 15
cd0(pciide0:1:0): using PIO mode 4, DMA mode 2
uhci0 at pci0 dev 4 function 2 "VIA VT83C572 USB" rev 0x10: irq 4
usb0 at uhci0: USB revision 1.0
uhub0 at usb0
uhub0: vendor 0x0000 UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1 at pci0 dev 4 function 3 "VIA VT83C572 USB" rev 0x10: irq 4
usb1 at uhci1: USB revision 1.0
uhub1 at usb1
uhub1: vendor 0x0000 UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
pchb1 at pci0 dev 4 function 4 "VIA VT82C686A SMBus" rev 0x30
auvia0 at pci0 dev 4 function 5 "VIA VT82C686A AC-97 Audio" rev 0x20: irq 10
ac97: codec id 0x43525934
ac97: codec features headphone, 20 bit DAC, 18 bit ADC, Spatializer 3D
audio0 at auvia0
xl0 at pci0 dev 13 function 0 "3Com 3c905B 100Base-TX" rev 0x30: irq 11
address 00:01:02:46:5c:d6
exphy0 at xl0 phy 24: 3Com internal media interface
vga1 at pci0 dev 15 function 0 "ATI Mach64 GX" rev 0x01
wsdisplay0 at vga1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pmsi0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pmsi0 mux 0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
sysbeep0 at pcppi0
npx0 at isa0 port 0xf0/16: using exception 16
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
biomask c050 netmask c850 ttymask d852
pctr: 686-class user-level performance counters enabled
mtrr: Pentium Pro MTRR support
dkcsum: wd0 matched BIOS disk 80
root on wd0a
rootdev=0x0 rrootdev=0x300 rawdev=0x302
xl0: watchdog timeout
xl0: watchdog timeout


They that can give up essential liberty to obtain a little temporary safety
deserve neither liberty nor safety.
 -- Benjamin Franklin (1706 - 1790)