[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: USB printer problem (/dev/lpt0: Device busy.)



On Thu, Oct 19, 2006 at 03:26:02AM -0200, m0f0x wrote:
> Hello,
> 
> This week I got a HP LaserJet 1022 BW laser printer (USB connection). This printer is marked as "works perfectly" in LinuxPrinting.org (yes, I know, BSD differs from Linux).
> 
> Well, first, I tried the printer on a friend's box, running Linux. The printer worked fine (CUPS) with the correct setup (filters, driver).
> 
> But, on my FreeBSD box, things didn't went very well. I saw a lot of users reporting the same problem that I'm having here: the USB port is always busy when the printer is attached.
> 
> The printer is recognized by the system without any problem:
> 	ulpt0: Hewlett-Packard HP LaserJet 1022, rev 2.00/1.00, addr 2, iclass 7/1
> 	ulpt0: using bi-directional mode
> 
> A simple test, the same test that were found on previous messages about this problem:
> 	lptest > /dev/lpt0
> 	/dev/lpt0: Device busy.
> 
> Well, I even tried to use a proposed patch to ulpt.c (http://lists.freebsd.org/pipermail/freebsd-usb/2005-July/001255.html), but no success.
> 
> Any clues/hints?

Try removing device plip from your kernel.  Something changed a while
back (I don't think anyone has tracked down what) that causes it to eat
the device.

-- Brooks

Attachment: pgpKAia7N7edv.pgp
Description: PGP signature