[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: old program compatibility with FreeBSD 6.1



On Saturday 13 May 2006 20:59, Dan Strick wrote:
> When I attempt to run a program compiled on release 5.4 under
> release 6.1, the system complains that it cannot find libc.so.5.
> On my release 5.4 system, /usr/lib/compat contains old shared
> libraries.  On my release 6.1 system, /usr/lib/compat contains
> only the aout subdirectory.
>
> Is this a bug in release 6.1?

I think you need to install ports/misc/compat5x

You can probably use your existing libraries by calling ldconfig but I don't 
see any reason to not do it "the right way".


-- 
Daniel O'Connor software and network engineer
for Genesis Software - http://www.gsoft.com.au
"The nice thing about standards is that there
are so many of them to choose from."
  -- Andrew Tanenbaum
GPG Fingerprint - 5596 B766 97C0 0E94 4347 295E E593 DC20 7B3F CE8C

Attachment: pgpKn9CB1t9qt.pgp
Description: PGP signature