[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Final 4.9-RC (i386) available now, please help test.



At 11:01 AM -0800 2003/10/26, Murray Stokely wrote:
>Ok, please try this :
>
>http://www.freebsd.org/~murray/4.8-20030801-snap.iso.bz2

	This worked for me.

	Now I am very confused. I was looking through my notes, and 
saw that I saw different behavior doing serial vs. VGA installs, so I 
installed 4.9RC4 via the physical (VGA) console, and it came up 
correctly. I then installed 4.9RC4 twice via serial console ("boot 
-hD"), and it was fine both times. I've since installed 4.9RC2 via 
VGA and serial 10-12 times (playing with BootEasy & no boot manager, 
and various other options), and it's been okay each time.

	Unless someone can figure out what was (but is no longer) 
biting me from the description, there seems nothing further to do on 
this issue at present.

	I'll sum up the history in hopes someone will have a clue 
what was wrong (bug report is "i386/58580: After sysinstall, F2 
fails; wrong device specified for /?".

		My posting 
<http://lists.freebsd.org/pipermail/freebsd-stable/2003-September/004048.html> 
said:

>>Booting [kernel]...
>>root device disk0s4a: invalid
>>
>>
>>
>>
>>Type '?' for a list of commands ...
>
>	lsdev showed my disk2 properly, and I was able to unload, set 
>currdev, and boot successfully. When I next rebooted, BootEasy 
>defaulted to F1 (DOS -- FreeBSD is F2). When I hit F2, FreeBSD 
>booted correctly (sending console output to the serial port). After 
>this, both F1 and F2 worked correctly.

	I reproduced this problem several times over a few days 
around September 30th.


	I can no longer reproduce the problem using the same CD-Rs. 
There's obviously a critical element I haven't identified, but I 
wonder if it's related to BIOS/BTX level disk names (I don't know 
much about the conventions).

	Booting 4.9RC4 off the hard disk, I now see (this works):

>BTX loader 1.00  BTX version is 1.01
>Console: internal video/keyboard
>BIOS drive A: is disk0
>BIOS drive C: is disk1

>ok lsdev
>cd @ 0xff5c
>disk @ 0xef68
>     disk0:   BIOS drive A:
>     disk1:   BIOS drive C:
>       disk1s1: FAT-32
>         disk1s2a: FFS
>         disk1s2b: swap
>         disk1s2e: FFS
>         disk1s2f: FFS
>         disk1s2g: FFS
>pxe @ 0xd6d8
>ok show
>LINES=24
>console=comconsole
>currdev=disk1s2a:
>interpret=ok
>kernel=/kernel
>kernel_options=
>kernelname=/kernel
>loaddev=disk1s2a:
>prompt=${interpret}


	Booting 4.9RC4 from the CD-ROM, I now see (this also works):

>BTX loader 1.00  BTX version is 1.01
>Console: internal video/keyboard
>BIOS drive A: is disk0
>BIOS drive B: is disk1
>BIOS drive C: is disk1

	lsdev shows:

>cd @ 0xff5c
>disk @ 0xef68
>     disk0:   BIOS drive A:
>         disk0a: FFS
>         disk0c: FFS
>     disk1:   BIOS drive B:
>     disk2:   BIOS drive C:
>       disk2s1: FAT-32
>         disk2s2a: FFS
>         disk2s2b: swap
>         disk2s2e: FFS
>         disk2s2f: FFS
>         disk2s2g: FFS
>pxe @ 0xd6d8

	currdev & loaddev are both "disk0s4a:" (which doesn't show up 
in lsdev, FWIW).


	Here's what sysinstall sees:

>Disk name:      ad0                                    FDISK Partition Editor
>DISK Geometry:  5169 cyls/240 heads/63 sectors = 78155280 sectors (38161MB)
>
>Offset       Size(ST)        End     Name  PType       Desc  Subtype    Flags
>
>          0         63         62        -      6     unused        0
>         63   12579777   12579839    ad0s1      2        fat       11
>   12579840   65575440   78155279    ad0s2      3    freebsd      165    C
>   78155280      10080   78165359        -      6     unused        0


>                          FreeBSD Disklabel Editor
>
>Disk: ad0       Partition name: ad0s2   Free: 0 blocks (0MB)
>
>Part      Mount          Size Newfs   Part      Mount          Size Newfs
>----      -----          ---- -----   ----      -----          ---- -----
>ad0s1     /c           6142MB DOS
>ad0s2a    /            1024MB UFS   Y
>ad0s2b    swap         1024MB SWAP
>ad0s2e    /var         1024MB UFS+S Y
>ad0s2f    /usr         6144MB UFS+S Y
>ad0s2g    /home       22803MB UFS+S N


	Thanks for everyone's assistance, and sorry I can't provide 
further info at this time.


						Chris Pepper
-- 
Chris Pepper:               <http://www.reppep.com/~pepper/>
Rockefeller University:     <http://www.rockefeller.edu/>