[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

How did I Break ssh? Solved.



	The problem is solved.  Sometimes, I have asked questions
on this list that later turned out to be a case of not reading
the manual and I felt properly embarrassed, etc.

	Here is what it was and all should pay attention if you
aspire to use a tar extraction to build or rebuild a system.

	I thought of what it might do to /dev, but since the
systems all use the same architecture and are all FreeBSD 4.7, I
figured that the extraction would essentially be writing the same
data back to /dev so it shouldn't matter.  That is wrong.

	Apparently, /dev/random no longer works after it is
overwritten although it can appear to.

	As soon as I did a MAKEDEV std, ssh came to life and is
now working as it should.

	Someone asked me if I had /dev/random which I did, but
that got me to thinking which lead me to remake all the standard
devices.  As far as I know, ssh was the only thing that did not
work because of this problem.  I would suspect that any
cryptographic software or anything else that uses random numbers
is effected.  The behavior of the system just screamed
permissions, but that wasn't it.  Other software may fail oddly
in other ways.

Visit your host, monkey.org