[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Help! Tape drive resets the server!



On Wednesday 27 August 2008 10:22:52 Kirk Strauser wrote:
> I have a Seagate DDS-4 tape drive:
>
> sa0 at sym0 bus 0 target 3 lun 0
> sa0: <SEAGATE DAT    9SP40-000 912L> Removable Sequential Access SCSI-3
> device sa0: 40.000MB/s transfers (20.000MHz, offset 16, 16bit)
>
> It's attached to a Tekram DC390F SCSI card:
>
> Is it possible that the drive itself is triggering the reset?  I'd find
> that a little unlikely, but am certainly not an expert on the matter. 
> Alternatively, has anyone had that sort of problem with drives attached to
> that card?

1) try a different scsi cable.
2) Are you using adapters? Get the right cable. One new, known good cable, no 
adapters.
3) Yes, it's possible that your drive is doing this, but more likely you have 
a bent pin/short somewhere causing the scsi bus to reset, and your kernel 
isn't handling this nicely. Check your pins. They bend easy, but a mechanical 
pencil with no lead in it can help you with that.
4) Is your termination auto or physical? 
5) Is the tape drive manually jumped for a specific ID? I assume that it is 
set for 3. Try 4.
6) Try a slower transfer rate.

Can you dump the SCSI sense codes that are being seen on the SCSI bus? That 
will most likely tell you whats going on right there.
_______________________________________________
freebsd-questions_(_at_)_freebsd_(_dot_)_org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscribe_(_at_)_freebsd_(_dot_)_org"