[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: serial console - no go



On Wed, 2008-08-27 at 10:43 +0200, Wojciech Puchar wrote:
> >>
> >> what i do wrong?
> >>
> > Have you checked flag setting on sio?
> >
> >        # dmesg | grep "sio.*flags"
> >        sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
> 
> yes. i then tried to change flags to 0x20 (force console) - still doesn't 
> work
> 
> sio0: configured irq 4 not in bitmap of probed irqs 0
> sio0: port may not be enabled
> sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x20 on acpi0
> sio0: type 16450
> sio0: [FILTER]
> sio1: configured irq 3 not in bitmap of probed irqs 0
> 
Careful, note the last sentence in the 0x20 flag description:

        0x20
                
                Forces this unit to be the console (unless there is
                another higher priority console), regardless of the -h
                option discussed below. The flag 0x20 must be used
                together with the 0x10 flag.

i.e. to use 0x20 you have to set it to 0x30

> 
> 
> it is qemu "machine" for now, but just to test, i would like to use it on 
> real hardware.
> 
Never tried, could be a qemu-specific issue?


Wayne


_______________________________________________
freebsd-questions_(_at_)_freebsd_(_dot_)_org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscribe_(_at_)_freebsd_(_dot_)_org"


Visit your host, monkey.org