[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [kde-freebsd] KDE4 libssl conflicts



On Tuesday 12 August 2008 12:43:37 Warren Liddell wrote:
> > You've got a mix of older and newer library versions, which makes
> > me think that you are trying to do a partial upgrade of your ports
> > after upgrading the FreeBSD base system to a newer version.  You
> > really need to rebuild all ports when doing that, or else you'll
> > run into issues.
> >
> > However, the specific problem you mention should have been resolved
> > by this change here:
> >
> >    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/126410
> >
> > ...so please double-check that your ports tree has been updated to
> > get this fix.
> >
> > Regards,
>
> I did recently upgrade my base system from 6.3-STABLE to 7.0-STABLE,
> however, i just re-ran a csup and ran portupgrade an tried a re-build
> of KDE4 with the same error output.

You need to clean out the 6.3 versions of various libs/binaries.

See the delete-old and delete-old-libs targets on /usr/src/Makefile


-- 
Andy Fawcett                                     | andy_(_at_)_athame_(_dot_)_co_(_dot_)_uk
                                                 | tap_(_at_)_kde_(_dot_)_org
"In an open world without walls and fences,      | tap_(_at_)_lspace_(_dot_)_org
  we wouldn't need Windows and Gates."  -- anon  | tap_(_at_)_fruitsalad_(_dot_)_org

_______________________________________________
freebsd-questions_(_at_)_freebsd_(_dot_)_org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscribe_(_at_)_freebsd_(_dot_)_org"