[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

php upgrade to 5.2.1 fails because of extensions



Hello,

I know this is not the php list but looking for your advice. I wanted to
upgraded php 5.1.6 to 5.2.1 because of vulnarabilities but it failed to
install extenstions. There seems to be an error with extenstions in 5.2.1.

I cannot downgrade (I issued  sudo portupgrade -m
-DDISABLE_VULNERABILITIES -f php5 changing the Makefile and distinfo
entries to point to 5.1.6 and issuing make makesum and got):

===>  Applying FreeBSD patches for php5-5.1.6_2
1 out of 1 hunks failed--saving rejects to ext/standard/string.c.rej
=> Patch patch-ext_standard_string.c failed to apply cleanly.
=> Patch(es) patch-TSRM_threads.m4 patch-Zend::zend.h patch-acinclude.m4
patch-configure.in patch-ext_date_lib_timelib_structs.h
patch-ext_standard_array.c patch-ext_standard_basic_functions.c
patch-ext_standard_dns.h patch-ext_standard_image.c applied cleanly.
*** Error code 1

Stop in /usr/ports/lang/php5.
** Command failed [exit code 1]: /usr/bin/script -qa
/tmp/portupgrade.55313.0 env PORT_UPGRADE=yes make WITH_CLI=1 WITH_CGI=1
WITH_APACHE=1 WITH_MULTIBYTE=1 WITH_IPV6=1 WITH_REDIRECT=1 WITH_DISCARD=1
WITH_FASTCGI=1 WITH_PATHINFO=1 WITH_OPENSSL=1 WITH_GETTEXT=1
-DDISABLE_VULNERABILITIES
** Fix the problem and try again.
** Listing the failed packages (*:skipped / !:failed)
        ! lang/php5 (php5-5.2.1_2)      (patch error)
--->  Packages processed: 0 done, 0 ignored, 0 skipped and 1 failed

Nor can I upgrade as these php5-extenstions won't install. Could anyone
advise what to do?

-- 
Zbigniew Szalbot


_______________________________________________
freebsd-questions_(_at_)_freebsd_(_dot_)_org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscribe_(_at_)_freebsd_(_dot_)_org"