[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Unable to upgrade subversion 1.4.2 to 1.4.3 (apache22 db4 support)



Hi list,

I'm trying to upgrade subversion from 1.4.2 to 1.4.3 (as part of a full
system update using 'portupgrade -a') but during compilation it aborts
with the following message:

You should build `www/apache22' with db4 support to use subversion with
it. Please rebuild `www/apache22' with option
`WITH_BERKELYDB=(db4|db41|db42)' and try again.

(or it suggests disabling db4 entirely with WITHOUT_DBD)

Since it doesn't seem like a bad idea to have the DB4 repository backend available I decided to recompile apache22 (version 2.2.4) with DB4 support by adding the following to the MAKE_ARGS list in /usr/local/etc/pkgtools.conf:

> 'www/apache22' => 'WITH_BERKELYDB=db42',

I ran portupgrade -f apache and made sure it was using this make argument. After recompilation of apache22 I tried to upgrade subversion again, but I'm still getting the exact same error. I checked /usr/ports/UPDATING to see if there's anything else I may need to do, but couldn't find anything.

Can someone tell me what I'm doing wrong here?
_______________________________________________
freebsd-questions_(_at_)_freebsd_(_dot_)_org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscribe_(_at_)_freebsd_(_dot_)_org"