[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problems with perl script on 6.1/5.8.8



I've got a perl script that just refuses to run on my new 6.1 box with Perl
5.8.8... Whenever I run it from the command line I get this:

Can't modify single ref constructor in lock at ./caldisp.pl line 84, near
"*LOCKF)"
Execution of ./caldisp.pl aborted due to compilation errors.

The lines in question are:

if (open (LOCKF, ">$LOCKF"))
{
    lock (\*LOCKF);
}

Now the script work fine on my older 4.10 box with perl 5.6.1.

Anyone have any ideas on how to fix this?

Thanks!!!

P.S. Thanks for the 'doh!' from everyone on the 'rm' with scp... I didn't
even think of just using ssh!

_______________________________________________
freebsd-questions_(_at_)_freebsd_(_dot_)_org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscribe_(_at_)_freebsd_(_dot_)_org"


Visit your host, monkey.org