[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

5.2RC2 - timeouts with tertiary IDE controller & CD-ROM



On Tue, 30 Dec 2003, MikeM wrote:

> > Yay timing issues. Your drive is jumpered for master and/or single
> > operation, yes?
>
> Unknown.   The CD-ROM drive is a no-name drive that has no documentation
> for the jumper(s).

Most of the CDROM drives I've come across have 3 settings, labelled MA,
SL, and CS.  Normally MA == Master & Single, SL == Slave, and CS == Cable
Select.  Make sure that MA is jumpered.

> > have you replaced the cable?
>
> I just replaced the cable with another, and I saw the same symptoms.
> Additionally, the previous cable has worked fine on FreebSD 4.9 and RH
> Linux 8.0 (can I say that here) when the CD-ROM is plugged into the
> tertiary IDE controller.  The previous cable also worked fine with FreeBSD
> 5.2RC2 when the the CD-ROM was plugged into the secondary IDE controller.

Good to check nonetheless.

5.2 has a newer ATA driver that did change the timings and such for
detection. There's a LOT of ATA devices that are really, really picky
about the timing.

-- 
Doug White                    |  FreeBSD: The Power to Serve
dwhite_(_at_)_gumbysoft_(_dot_)_com          |  www.FreeBSD.org

Visit your host, monkey.org