[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: IPV6 problem : nd6_lookup: failed to add route for a neighbor



Tuc at T-B-O-H.NET wrote:
Hi,

	Running 5.5 (And no "upgrade" messages please, I'm forced to, its
out of my hands) and trying to bring up HE's IPV6.

	I've got it running on a 4.10 system (Ok, feel free to tell me
to upgrade, this one is more a lazy issue.. But I am making progress. I
bought new drives that'll be here next week so I can load 7.0 from
scratch) with no worries at all. Piece of cake, has been for ages.

	But once I brought it all up, I got :

kernel: nd6_lookup: failed to add route for a neighbor(2001:0470:0007:0028::0001), errno=17

	and ALOT of them. Taking a quick look in Google, it seems that they claim
its a prefix len issue, but I am running with a 128 prefix length even though it seems
they say :

Client IPv6 address:  	2001:470:7:28::2/64

The script they suggest, and I used, is :

ifconfig gif0 create
ifconfig gif0 tunnel MYIP 216.66.22.2
ifconfig gif0 inet6 2001:470:7:28::2 2001:470:7:28::1 prefixlen 128
route -n add -inet6 default 2001:470:7:28::1
ifconfig gif0 up

	The tunnel came up, was passing traffic, but those messages were
getting out of hand. I tried a prefixlen of 64, and I got:

...hmmmm. I'm not certain here, but since /128 represents only a single address, I can understand why FreeBSD is getting confused. A /128 is an IP within its own solitary subnet, so I'd have to guess that you need a route to the remote end of the tunnel before you can set it as a default gateway.

I've been needing to set up a few more tunnels, so I'll try one with FreeBSD this morning with the same setup you have to try to replicate the problem (on 7.0).

	ifconfig: ioctl (SIOCAIFADDR): Invalid argument

What was the command that you had entered when you received the above error? When you tried to change prefix length, did you destroy the existing tunnel first?

Sendmail seemed a bit cranky :

Jun 26 23:53:19 MYHOST sendmail[17543]: gethostbyaddr(IPv6:2001:470:7:28::2) failed: 1

I believe this is a reverse DNS issue. From how I perceive that message, Sendmail is trying to retrieve a hostname based on that IP.

Steve
_______________________________________________
freebsd-net_(_at_)_freebsd_(_dot_)_org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-net
To unsubscribe, send any mail to "freebsd-net-unsubscribe_(_at_)_freebsd_(_dot_)_org"


Visit your host, monkey.org