[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: MFC of em/igb drivers



Jack Vogel wrote:
I got the new drivers in Friday afternoon for those that don't see CVS
messages.

The igb driver is for 82575 and 82576 adapters, it has multiqueue support and
MSIX, there will be more server type enhancements in that driver as I get the
time.

The em driver now will be client oriented, the latest hardware support however
is for 82574, Hartwell, which is a really nice low cost PCIE dual-port adapter,
that actually also has MSIX. This first released support for it will
use 3 interrupt
vectors, one for TX, one for RX, and Link. The hardware actually supports 5
vectors, so I am planning to add support for another RX and TX queue as my
schedule allows.

Hartwell is also the first adapter that has IEEE 1588 PTP support, the driver
provides init and an ioctl interface to use that facility, I hope we
see software
support follow on soon. This is an early announcement, I am not sure on
exact dates for availability but they should be soon.

As ever, issues and bugs should be sent to me. Cheers everyone!

Jack

Jack,

I have Intel Gigabit card and FreeBSD-7.0-STABLE recognizes it as following:
...
em0_(_at_)_pci0:0:25:0: class=0x020000 card=0x2800103c chip=0x104a8086 rev=0x02 hdr=0x00
   vendor     = 'Intel Corporation'
   device     = '82566DM Gigabit Network Connection'
   class      = network
   subclass   = ethernet
...
# uname -an
FreeBSD test.ub.mng.net 7.0-STABLE FreeBSD 7.0-STABLE #0: Thu Jun 5 11:12:34 ULAT 2008 tsgan_(_at_)_test_(_dot_)_ub_(_dot_)_mng_(_dot_)_net:/usr/obj/usr/src/sys/FIREWALL i386


It has some problem, 1000baseTX connection status almost never goes to active in bridged mode, sometimes it goes to active but then immediately it goes to no carrier. (The other end is Cisco4507R, Gigabit Ethernet port)
...
em0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
   options=198<VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4>
   ether 00:0f:fe:82:23:db
   media: Ethernet 1000baseTX <full-duplex> (autoselect)
   status: no carrier
...

Any idea how to solve this issue?

thanks,

Ganbold


_______________________________________________
freebsd-net_(_at_)_freebsd_(_dot_)_org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-net
To unsubscribe, send any mail to "freebsd-net-unsubscribe_(_at_)_freebsd_(_dot_)_org"





--
Q: How many pre-med's does it take to change a lightbulb? A: Five: One to change the bulb and four to pull the ladder out from under him.
_______________________________________________
freebsd-net_(_at_)_freebsd_(_dot_)_org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-net
To unsubscribe, send any mail to "freebsd-net-unsubscribe_(_at_)_freebsd_(_dot_)_org"


Visit your host, monkey.org