[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

IP-forwarding (help)



Hello,

this is probably a FAQ and/or I'm to tired, but I'd be pleased
if anyone can tell me what I do wrong :

I have a box with two interfaces, one connected to my lan
(172.16. ), one to a test-box (192.168.1.1) :

  em0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=9b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM>
        ether xxx
        inet 172.16.1.240 netmask 0xffffff00 broadcast 172.16.1.255
        media: Ethernet autoselect (1000baseTX <full-duplex>)
        status: active

  em1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=9b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM>
        ether xxx
        inet 192.168.1.254 netmask 0xffffff00 broadcast 192.168.1.255
        media: Ethernet autoselect (1000baseTX <full-duplex>)
        status: active


I enable ip.forwarding :

  # sysctl net.inet.ip.forwarding
  net.inet.ip.forwarding: 1


And this is my routing table :

 Internet:
 Destination        Gateway            Flags    Refs      Use  Netif Expire
 default            172.16.1.254       UGS         0       20    em0
 127.0.0.1          127.0.0.1          UH          0        0    lo0
 172.16.1.0/24      link#3             UC          0        0    em0
 172.16.1.6         xxxxxxxxxxxxxxxxx  UHLW        1       87    em0   1194
 172.16.1.230       xxxxxxxxxxxxxxxxx  UHLW        1      286    em0    572
 172.16.1.240       xxxxxxxxxxxxxxxxx  UHLW        1        0    lo0
 172.16.1.254       xxxxxxxxxxxxxxxxx  UHLW        2        0    em0    487
 192.168.1.0/24     link#4             UC          0        0    em1
 192.168.1.1        xxxxxxxxxxxxxxxxx  UHLW        1        2    em1    616
 192.168.1.254      xxxxxxxxxxxxxxxxx  UHLW        1        0    lo0

For this I added to rc.conf :

  static_routes="test lan"
  route_test="-net 192.168.1.0/24 192.168.1.254" 
  route_lan="-net 172.16.1.0/24 172.16.1.240"

Now from my test-box 192.168.1.1 I can reach (of course) 192.168.1.254,
I can reach 172.16.1.240, but no other IP.

What do I wrong, please!?

Thank you very much for any help in advance.

Best regards, Arno
_______________________________________________
freebsd-net_(_at_)_freebsd_(_dot_)_org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-net
To unsubscribe, send any mail to "freebsd-net-unsubscribe_(_at_)_freebsd_(_dot_)_org"


Visit your host, monkey.org