[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Xircom/cardbus in 7-RELEASE



WATANABE Kazuhiro wrote:
Hello,

At Sun, 12 Oct 2008 12:30:51 -0500,
Steven Susbauer wrote:
Good day,

I posted to questions but did not get any response, I was told to try here.
I appear to be experiencing a problem that is similar to
http://unix.derkeiler.com/Mailing-Lists/FreeBSD/current/2006-10/msg00226.html
Unfortunately in that thread it doesn't appear to have been resolved.

When I am using 6.3-RELEASE, my IBM EtherJet 10/100 cardbus card works
fine. On boot I receive:


<SNIP>



On 7-RELEASE the ports are recognized still, but I receive:

cardbus0: Unable to allocate resource to read CIS.
cardbus0: Unable to allocate resources for CIS
dc0: <Xircom X3201 10/100BaseTX> port 0x1000-0x107f mem
0x88000000-0x880007ff, 0x88001000-0x880017ff irq 11 at device 0.0 on
cardbus0
dc0: No station address in CIS!
device_attach: dc0 attach returned 6

How about a patch described this PR?

kern/115623: [cardbus] [patch] Xircom CardBus Ethernet II 10/100 Adapter (CBE2-100) doesn't work [regression]
 http://www.freebsd.org/cgi/query-pr.cgi?pr=kern%2F115623&cat=


That seems to have fixed it. The patch on the site had a broken layout
but it was fine in the original message at
http://lists.freebsd.org/pipermail/freebsd-bugs/2007-December/027280.html.
Can't wait for this to end up in the actual tree.

Thanks for pointing this out, now I know another place to look for
issues and fixes as well.

-Steve


_______________________________________________
freebsd-mobile_(_at_)_freebsd_(_dot_)_org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-mobile
To unsubscribe, send any mail to "freebsd-mobile-unsubscribe_(_at_)_freebsd_(_dot_)_org"


Visit your host, monkey.org