[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

mozilla 1.3,2 cannot access IPv6 addressed host via IPv4



On Thu, 2003-04-10 at 09:44, Hiroharu Tamaru wrote:
> Hi,
> 
> gnome@ CC:'ed 'causs it's the maintainer of the port.
> 
> At Wed, 9 Apr 2003 17:44:21 +0200,
> Christoph P. Kukulies wrote:
> > 
> > On Wed, Apr 09, 2003 at 11:48:33PM +0900, Hiroharu Tamaru wrote:
> > > I updated mozilla port from 1.2.1_1,2 to 1.3,2 and realized that
> > > it fails to reach some sites.  It just says "Done" in the status bar
> > > and nothing happens.
> > > 
> > > It seems to be those servers that have both IPv4 and IPv6 address that
> > > are the victims, eg: www.jp.freebsd.org, www.kame.net.
> > > 
> > > I am running FreeBSD 4.8-RC. I have IPv6 lladdr assigned to my
> > > network interfaces but do not have IPv6 link to the Internet.
> > > 
> > > Am I the only one seeing this problem?
> > 
> > The problem has brought up by me in this list already before,
> > only not under this aspect. 
> > 
> > The workaround was, so far, to turn off IPV6 in the kernel.
> > 
> > I admit, not a beautiful solution. I posted an excerpt (sample program
> > that had been posted to bugzilla on mozilla.org under some bug report)
> > 
> > Look into this list under posts this and last week.
> 
> Indeed you did.  I saw 1.4 in the subject and didn't read it carefully then.
> 
> I also found the same issue reported on gnome@
> http://www.freebsd.org/cgi/getmsg.cgi?fetch=1019068+0+/usr/local/www/db/text/2003/freebsd-gnome/20030223.freebsd-gnome
> 
> OK. I brought it up to users-jp_(_at_)_jp_(_dot_)_freebsd_(_dot_)_org ML and someone pointed
> out that it was assigned a bugzilla-JP id of 2967
> http://bugzilla.mozilla.gr.jp/show_bug.cgi?id=2967
> 
> and forwarded to bugzilla
> 
> http://bugzilla.mozilla.org/show_bug.cgi?id=192696
> http://bugzilla.mozilla.org/show_bug.cgi?id=186745
> 
> He told me a fix is already committed to the trunk of Mozilla repo.
> 
> also, reading through bugzilla 186745, the patch,
> http://bugzilla.mozilla.org/attachment.cgi?id=112566&action=view
> is said to work around the problem, with some impact on IPv6-only
> users.
> 
> I tried the patch, and it seems to work for me.
> Could someone commit the above mentioned one line patch to the mozilla
> port?

Committed.  Thanks for reporting.

Joe

-- 
PGP Key : http://www.marcuscom.com/pgp.asc


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: This is a digitally signed message part
Url : http://lists.freebsd.org/pipermail/freebsd-gnome/attachments/20030414/ada90a33/attachment.bin

Visit your host, monkey.org