[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Very slow performance while compiling/using X software on AMD64/Nforce3 7.0-CURRENT



Hi,

I installed -CURRENT recently on a AMD64/Asus K8N, buildworld'ed/buildkernel'ed without the debugging stuff, and I've got several problems.

I was running Gentoo before, and everything was running smoothly. I was able to, for example, playing music while compiling, or using firefox.

Right now, when I try to play music while compiling, I've got lag. It clicks, and I'm unable to listen to music normally. When Firefox loads a page, it clicks too. Simple operations like changing of virtual desktops give the same result.

I first suspected the scheduler. I used 4BSD, tried to switch tu ULE2. It was worst. I then tried CORE, same thing.

I then checked DMA :

# sysctl -a | grep dma
[snip]
hw.ata.atapi_dma: 1
hw.ata.ata_dma: 1

# atacontrol mode ad0
current mode = UDMA100

Seems to run normally.

As I'm fairly new to the BSD world, I don't know what to check or suspect.

I've spotted weird CPU usage by xorg, or by software supposed to be lightweight (xfterminal for example, while compiling and scrolling the window gave me heavy load). Standard xorg port, and modular xorg gave me the same result (I'm currently running under modular).

I suspect that my configuration (MergedFB on ATI Radeon 9200) could be a problem.

Is there anything to check to look for the right cause of this problem ?

You can find my kernel config file, my xorg.conf, an output of dmesg, and lspci right there : http://www.calaquendi.org/freebsd/

Thanks,

--
Julien Cassignol.
_______________________________________________
freebsd-amd64_(_at_)_freebsd_(_dot_)_org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-amd64
To unsubscribe, send any mail to "freebsd-amd64-unsubscribe_(_at_)_freebsd_(_dot_)_org"