[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Can't compile jdk15 on amd64 5.3-STABLE



Hi,

So far I've been running linux-sun-jdk-1.4.2.06_1 successfully on my box and 
works great in konqueror but not at all in firefox. So I tried to compile 
jdk15 and it gives me the following error:

<snip>
execv(): Bad address
Error trying to exec /usr/local/linux-sun-jdk1.4.2/bin/javac.
Check if file exists and permissions are set correctly.
gmake[3]: *** [.compile.classlist] Error 1
gmake[3]: Leaving directory `/usr/ports/java/jdk15/work/j2se/make/java/java'
gmake[2]: *** [all] Error 1
gmake[2]: Leaving directory `/usr/ports/java/jdk15/work/j2se/make/java'
gmake[1]: *** [all] Error 1
gmake[1]: Leaving directory `/usr/ports/java/jdk15/work/j2se/make'
gmake: *** [j2se-build] Error 2
*** Error code 2

Stop in /usr/ports/java/jdk15.

I googled around and found 
http://lists.freebsd.org/pipermail/freebsd-java/2005-February/003446.html and 
several replies but no real fix for me. Apparently I'm not the only one in 
this situation.

>From what I understand, the command "javac" that is executed before the fail 
point is 25814 characters long and on my 5.3-STABLE machine I max out at 
16384 characters (according to many configure scripts). I tried copy pasting 
the javac command but I max out of the buffer near the middle of the command 
whether I use Konsole, Xterm or good-old ttyv + csh.  

Jdk15 compiles fine on my -CURRENT amd64 machine but I would like to have it 
work on my stable one as well.

Any solutions?

Thanks,
Nicolas.

Visit your host, monkey.org