[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: PCIe bridges resources disappearing with ACPI enabled.



John Baldwin wrote:
On Saturday 25 October 2008 06:43:44 pm Alexander Motin wrote:
Hi.

I have spent whole day trying to investigate strange problem of my Acer
TM6292 laptop (965GM+ICH8M). When booted with ACPI enabled, all three
of PCIe-to-PCIe bridges appearing completely without I/O resources:
pcib1: <ACPI PCI-PCI bridge> irq 17 at device 28.0 on pci0
pcib1:   domain            0
pcib1:   secondary bus     2
pcib1:   subordinate bus   3
pcib1:   I/O decode        0x0-0x0
pcib1:   no prefetched decode
...
At the same time, with ACPI disabled, resources are present. There are
some different problem with IRQ in that case, but it is another
question, not so interesting to me.

I have tried both IO and memory mapped PCIe configuration registers without success.

I have made heavy digging trying to find where resources disappearing. I
have even added debug printing inside pcireg_cfgwrite() and
pciereg_cfgwrite() to trace if somebody erases it and found nothing.
Nothing writes into that devices configuration registers.

The SMI handle could be clearing the BARs when ACPI is enabled for some reason. Windows and Linux are smart enough to alloc resources for bridges, but FreeBSD isn't yet.


Thanks for a good tip. Elimination of "Store (Zero, SMIC)" string from ASL code has solved the problem.
_______________________________________________
freebsd-acpi_(_at_)_freebsd_(_dot_)_org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-acpi
To unsubscribe, send any mail to "freebsd-acpi-unsubscribe_(_at_)_freebsd_(_dot_)_org"


Visit your host, monkey.org