[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Broken Compaq ML530 G1 ACPI.



Hi everyone,

I finally upgraded to 6.1-RELEASE and the machine can now boot. There
are still a lot of ACPI related errors, but at least it comes up.

That is quite strange, because 5.3-RELEASE did not have this problem.

ACPI Newbie question: Can we take the ACPI code from 5.3 and place it
into 6.1 to clear this problem???

Here's what is displayed:

FreeBSD 6.1-RELEASE #2: Tue May  9 14:40:21 EDT 2006
   root_(_at_)_scholastica_(_dot_)_notarius_(_dot_)_com:/usr/obj/usr/src/sys/CML530
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel Pentium III Xeon (996.85-MHz 686-class CPU)
 Origin = "GenuineIntel"  Id = 0x686  Stepping = 6
Features=0x383fbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE>
real memory  = 1207943168 (1151 MB)
avail memory = 1173516288 (1119 MB)
ACPI APIC Table: <COMPAQ 00000083>
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
cpu0 (BSP): APIC ID:  1
cpu1 (AP): APIC ID:  0
   ACPI-0377: *** Info: Table [SSDT] replaced by host OS
ACPI: overriding DSDT/SSDT with custom table
   ACPI-0377: *** Info: Table [DSDT] replaced by host OS
ioapic0: Changing APIC ID to 8
MADT: Forcing active-low polarity and level trigger for SCI
ioapic0 <Version 1.1> irqs 0-34 on motherboard
acpi0: <COMPAQ RACEBAIT> on motherboard
acpi0: Power Button (fixed)
   ACPI-0252: *** Error: No object was returned from
[\\_SB_.FAKE._CRS] (Node 0xc4e4e580), AE_NOT_EXIST
can't fetch resources for \\_SB_.FAKE - AE_NOT_EXIST
   ACPI-0252: *** Error: No object was returned from
[\\_SB_.FAKE._CRS] (Node 0xc4e4e580), AE_NOT_EXIST
Timecounter "ACPI-safe" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x240-0x243 on acpi0

David

On 5/9/06, Chris Howells <howells_(_at_)_kde_(_dot_)_org> wrote:



---------- Forwarded message ----------
From: Chris Howells <howells_(_at_)_kde_(_dot_)_org>
To: freebsd-acpi_(_at_)_freebsd_(_dot_)_org
Date: Tue, 09 May 2006 18:08:07 +0100
Subject: Re: Broken Compaq ML530 G1 ACPI.
David Robillard wrote:

> We have some Compaq ML530 G1 machines and I would like to upgrade them
> to FreeBSD 6.0-RELEASE-p7. Unfortunately, the ACPI seems to be broken
> and the systems freeze when booting with ACPI.

It might be worth trying 6.1.

> I did not find a whole lot of info on the mailing list archives. Just
> this post
> http://lists.freebsd.org/pipermail/freebsd-acpi/2005-December/002324.html
> from which I tried the patch. But it fails to compile.

The "patch" only consists of adding a few printf's to the kernel to get
more debugging information, so it'd be interesting to know what the
compile error is.
_______________________________________________
freebsd-acpi_(_at_)_freebsd_(_dot_)_org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-acpi
To unsubscribe, send any mail to "freebsd-acpi-unsubscribe_(_at_)_freebsd_(_dot_)_org"





--
David Robillard
david_(_dot_)_robillard_(_at_)_gmail_(_dot_)_com
Montreal: +1 514 966 0122
_______________________________________________
freebsd-acpi_(_at_)_freebsd_(_dot_)_org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-acpi
To unsubscribe, send any mail to "freebsd-acpi-unsubscribe_(_at_)_freebsd_(_dot_)_org"